Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Patches
  • Category Playlists
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by aliask - 2006-09-11
Last edited by aliask - 2007-08-03

FS#5969 - Track skip in repeat-1 mode skips the track

Previously skipping a track in repeat-1 mode would start playback again of the same track.
As dongs pointed out on IRC (repeatedly) from his detailed studies of many people this is unintuitive.

So here the fix is.

Closed by  aliask
2007-08-03 13:48
Reason for closing:  Invalid
Additional comments about closing:  

Patch completely useless, perhaps this could be opened as a feature request if anyone feels it's necessary. No point leaving the task open.

Project Manager

I honestly don't believe that disabling the Repeat-1 function is the way to solve this.

Oh boy am I red faced. I guess I should have tested this a bit more before testing it hey :)

Project Manager

Hehe. :-)

As you can see, the problem is that the repeat-1 is handled at the playlist level by building a playlist with only 1 track and letting it repeat. This is why it isn't easy to fix this issue.

A possible solution would be to handle the repeat-1 in the playback code instead, so it only calls playlist_next() when actually skipping a track.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing