Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category User Interface
  • Assigned To No-one
  • Operating System All players
  • Severity High
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by splinter - 2006-09-11
Last edited by safetydan - 2006-09-11

FS#5970 - I40:PDIR1FULL at 00000007 error view for full details

I found this dodgy error/glitch in the latest rockbox build.
This is what happens
I load up the fm radio then hold down navi, I then go to sound settings then equalizer then advanced eq settings then low shelf filter.
This is where rockbox freezes iriver and and the following error is displayed:

I40:PDIR1FULL
at 00000007

Not sure where to put this error because it only happens in Fm tuner yet it doesnt actualy happen in fm tuner it just happens if your running fm tuner.

Closed by  petur
2006-09-16 19:53
Reason for closing:  Fixed
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407

This is the easiest way to fix. The reason why one would want to change the EQ while in FM radio is another question. Would only be usefull if the sound of the radio passes through the playback engine…

This is caused by Rockbox running out of menus. Sounds like an odd error I know, but that’s what’s going on. The simple fix is to increase the menu buffer (i.e. change MAX_MENUS in apps/menu.c to 6), but I’m not sure if that’s the right fix as it’s pretty rare to have menus nested six deep.

Warning: Undefined array key "useheading" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 1099 Warning: Undefined array key "target" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 Warning: Trying to access array offset on value of type null in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557

The same error message (with a different address) appears in the Recording Screen. See http://www.rockbox.org/tracker/task/5952 There it was identified as overrun FIFO used during DMA transfers.

I think that bug is a different crash since I can reproduce this one in the simulator and the error is definitely “Out of menus”.

Another one (on H300). Go to Info > Debug (Keep Out!) > View Battery. Result is: I40:PDIR1FULL at 00000002.

sounds like theres definatly something wrong here that needs to be fixed.

petur commented on 2006-09-16 19:36

FIXED: Info > Debug (Keep Out!) > View Battery. Result is: I40:PDIR1FULL at 00000002.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing