Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Playlists
  • Assigned To No-one
  • Operating System All players
  • Severity Medium
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by crasus - 2006-09-16
Last edited by bluebrother - 2007-09-20

FS#6005 - Reordering Currently playing Playlist is Inconsistent

I noticed that reordering the currently playing playlist using the move function acts inconsistently.

If I have songs ordered like this, and I am playing Track 3.

Track 1
Track 2

>Track 3

Track 4
Track 5

Example 1. Moving Track 3 and postitioning the cursor so Track 1 is highlighted and selecting it the following happens.

Track 1
Track 2
Track 4
Track 5

>Track 3
So Track 3 doesent end up at the top of the list (which is what the user intended) but gets put at the bottom. This happens even if the song you are moving is not being played.

Example 2. Moving Track 3 and postitioning the cursor so Track 5 is highlighted and selecting it the following happens.

Track 1
Track 2
Track 4

>Track 3

Track 5

So Track 3 does not end up at the bottom of the list (which is what was intended) but gets put before the last track.

Example 3. Moving a track from underneath the currently playing e.g. Track 5 and postitioning the cursor so Track 3 (the currently playing track) is highlighted and selecting it the following happens.

Track 1
Track 2
Track 5

>Track 3

Track 4

The track gets placed on top of the currently palying track.

Example 4. Moving a track above the currently playing track e.g. Track 1 and postitioning the cursor so Track 3 (the currently playing track) is highlighted and selecting it the following happens.

Track 2

>Track 3

Track 1
Track 4
Track 5

The track gets placed underneath the currently palying track.

Behavior between examples 3 and 4 is inconsistent. A similar inconsistency happens when reodering tracks around the currently playing track. It seems to me that the behavior in these cases should always be the same so the track always gets put underneath the selected track or above it.

This is as long as Examples 1 and 2 act intuitively. That is if you select the track at the top of the list, you want the track you are moving to go to the top. And if you select the track at the bottom you want the track at the you are moving at the bottom of the list.

Closed by  bluebrother
2007-09-20 06:37
Reason for closing:  Out of Date
Additional comments about closing:  

no response

Thanks for the detailed bug report. I was able to reproduce and have fixed the first example. However, I have not been able to reproduce examples 2-4. Would you try the latest CVS build and see if they still reproduce please.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing