Rockbox

Tasklist

FS#6006 - Insert still not fucntioning correctly

Attached to Project: Rockbox
Opened by Joaquim Dias (dunno) - Saturday, 16 September 2006, 07:14 GMT
Last edited by Dave Chapman (linuxstb) - Saturday, 16 September 2006, 16:45 GMT
Task Type Bugs
Category Playlists
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hardeep, sorry but "Insert" is still not correct after downloading the latest bleeding edge. Using file tree.

playlist contains tracks 1 2 3 and playing 1,

this is what Insert does,

Insert A -> 1 2 3 A

when its supposed to do this,

Insert A -> 1 A 2 3
This task depends upon

Closed by  Hardeep Sidhu (hardeeps)
Saturday, 16 September 2006, 17:27 GMT
Reason for closing:  Invalid
Additional comments about closing:  This is correct behaviour.
Comment by Jonas Häggqvist (rasher) - Saturday, 16 September 2006, 07:19 GMT
It is not possible to see from your example if this is wanted or unwanted behavior without knowing how the list "1 2 3" was created.
Comment by Joaquim Dias (dunno) - Saturday, 16 September 2006, 07:31 GMT
original playlist 1 2 3 was creayed using Insert only, but it doesn't matter as Insert still doesn't exhibit correct behaviour as stipulated and discussed before, at any time.
Comment by Jonas Häggqvist (rasher) - Saturday, 16 September 2006, 07:33 GMT
Insert is supposed to insert after the last inserted track, so it would seem that it is functioning correctly as far as I can see.
Comment by Joaquim Dias (dunno) - Saturday, 16 September 2006, 07:43 GMT
I created a new playlist using Insert for the first three tracks, and this is the behaviour I get form Insert.
Playing 1
1). Insert A -> 1 2 3 A
2). Insert B -> 1 2 3 A B
3). Insert Next C -> 1 C 2 3 A B
4). Insert D -> 1 C 2 3 A B D

hmm, on second thoughts this doeas appear correct, my mistake, deleate this please.
Comment by Jonas Häggqvist (rasher) - Saturday, 16 September 2006, 07:47 GMT
Now I'm in favour of keeping this open though. I would expect step 4 to insert D after C (the most recently inserted track).

Can someone more familiar with the playlist handling enlighten us? Is this is correct behavior?
Comment by Hardeep Sidhu (hardeeps) - Saturday, 16 September 2006, 17:14 GMT
Jonas,

Yes, this is correct behaviour based on the current implementation. We only track the last insert position of "Insert"ed tracks, not ones that used "Insert Next" or "Insert Last".

Joaquim,

Just to confirm, you created your playlist by inserting one track at a time? If so then yes, this is not a bug.

-Hardeep

Loading...