Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Plugins
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by PaulJam - 2006-09-16
Last edited by jdgordon - 2007-08-05

FS#6007 - TextViewer bugs

1. If you are in narrow view mode and the text contains a string of characters that has a “-” in it, where the part of the sring after the “-” is so long that it doesn’t fit on a single line (for example a long URL), it happens, that only the part in front of the “-” is shown, and the following lines in the text remain blank and you can’t scroll down any further.

Example:

The textfile contains the following text:

aaaaaaaa
bbbbb-cccccccccccccccccccccccccccccccccccccccc
ddddddddd

it only shows:

aaaaaaaa
bbbbb

If a longer text contains such a string, and you are at the end of the file and try scroll up to the position of this string the player (in this case a H300) freezes.

2. If you watch a textfile in wide view and scroll some columns to the right and then change the view to narrow, then the viewer doesn’t use the full display width and parts of the textlines are missing/not shown. It seems as if the view stays scrolled to the left and so the first few characters (depending on how much you scrolled right in wide view) of each line outside the visible area.

3. If you scroll down (paged scrolling) in a long text file, after a while audio playback pauses until you stop scrolling.

Closed by  jdgordon
2007-08-05 04:16
Reason for closing:  Fixed
Additional comments about closing:  

quick hack commited to fix point 1, so can finally close this

point 2 is fixed,
3 is because its not yielding enough (hopefully Slasheri’s new schedular fixed this tho, let us know if i should add a yield call in to fix this)

point 1 is beyond my level of understanding of the code

I confirm that 3 is fixed on iriver H100 series.

Is point 1 still valid? Could you please check and report?

unless there has been a commit saying otherwise i belive it is still valid

The bug still exists in current CVS (at least in the uisimulator).
To reproduce it open the textfile
http://www.rockbox.org/irc/rockbox-20060914.txt in the viewer plugin and scroll (in narrow mode) down to timeindex 01.06.33. The join message is only shown half and the text behind that is missing.

The workaround i’m using is to remove the part
,’-’ near the end of line 242 of the file apps/plugins/viewer.c (version 1.49)
but i don’t think this is a proper fix for this problem.

I can’t reproduce 1. on my H300 using SVN (I copied your example to a new text file). Please try a current build and see if the issue still exists. Note: I don’t see any commits that would have fixed this though….

After further testing, I have been able to reproduce the bug so it’s still an issue in current SVN.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing