Rockbox

Tasklist

FS#604 - ID3 info not being displayed (Rioport id3v2 bug)

Attached to Project: Rockbox
Opened by Anonymous Submitter - Monday, 09 December 2002, 13:39 GMT
Last edited by Daniel Stenberg (bagder) - Friday, 05 December 2003, 09:36 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Daily builds after 12/01/2002 do not display all of the ID3
information on some (not all) of my MP3's (Builds
11/30/2002 and earlier properly display this info)

This seems to affect MP3's that I ripped using Rioport
audio manager - MP3's ripped with MusicMatch display
OK.

Jukebox Recorder 20
Firmware 1.28
HW Info:
ROM: 1.28
Mask: 0x0302
USB: positive
ATA: 0x200
PR: positive
Freq: 11.0592MHz
This task depends upon

Closed by  Daniel Stenberg (bagder)
Friday, 05 December 2003, 09:36 GMT
Reason for closing:  Wont Fix
Comment by Björn Stenberg (zagor) - Monday, 09 December 2002, 14:31 GMT

Can you upload an exampe to use for debugging?
Comment by Anonymous Submitter - Tuesday, 10 December 2002, 00:53 GMT

Here is an MP3 that displays properly in the earlier builds,
but not in the later ones.

Thanks for all your efforts.

Michael
mfacelle@familink.com
Comment by Anonymous Submitter - Tuesday, 10 December 2002, 01:28 GMT

Sorry...

I'm trying to upload an MP3 for an example, but I can't
figure out how to attach a file to a follow up comment. I
started a new thread to attach the file, but it was too big
and did not attach ( the file is ~1.2M).

Is there an easy way to 'truncate' an MP3 so I can upload
it?

Michael
mfacelle@familink.com
Comment by Anonymous Submitter - Tuesday, 10 December 2002, 01:29 GMT

Sorry...

I'm trying to upload an MP3 for an example, but I can't
figure out how to attach a file to a follow up comment. I
started a new thread to attach the file, but it was too big
and did not attach ( the file is ~1.2M).

Is there an easy way to 'truncate' an MP3 so I can upload
it?

Michael
mfacelle@familink.com
Comment by Anonymous Submitter - Tuesday, 10 December 2002, 02:07 GMT

Finally... chopped up an MP3 using WordPad, and posted
it under thread #651224 (I still can't see how to attach a
file to a followup comment)

Thanks

Michael
Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 10 December 2002, 12:07 GMT

I have examined your file and I saw what was wrong. Rioport
has the silly habit of adding empty ID3 frames (length = 0)
in the tag. I quote from the ID3V2.3 specification:

"A frame must be at least 1 byte big, excluding the header."

So Rioport violates the ID3V2 standard. Send them an email
and complain about them generating invalid ID3V2.3 tags.


FYI, we added the length=0 check the 28th of October.

The reason it worked for you may be that the "working" files
contain both V1 and V2 tags. December 3 we changed the ID3
code so it ignores the V1 tag if there is a V2 tag. So now
it tries to use the V2 tag, encounters the invalid frame and
aborts.
Comment by Anonymous Submitter - Tuesday, 10 December 2002, 14:34 GMT

Thanks for all your help.

You guys are doing a great job!!!!

Michael
mfacelle@familink.com
Comment by Anonymous Submitter - Wednesday, 08 January 2003, 11:59 GMT

I've just found the same problem, having downloaded the
lastest daily build.
any suggestions for how I can see if it's caused by the same
empty frame issue? (a binary sequence to look for in the
file, perhaps?)

I only have it on some MP3s, and I'm guessing that they're
the ones I did when I was using Real Jukebox, which I
stopped using some time ago now.

If it is the same cause, I'll just try to fix the broken MP3s.

Thanks,
Rob

rockbox@woozle.dircon.co.uk

Loading...