Rockbox

Tasklist

FS#6054 - iHP140 freezes on activating CROSSFADING

Attached to Project: Rockbox
Opened by Tobi (MickeyKnox) - Sunday, 24 September 2006, 09:58 GMT
Last edited by Rani Hod (RaeNye) - Monday, 25 September 2006, 12:58 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System Iriver H100 series
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi

A friend of mine did show me your website yesterday and I got pretty excited about all the features you offer for my good OLD iHP140, so I downloaded and installed it and what can I say? FANTASTIC ... I really love what you did, it's incredible. I always thought that this little machine could do much more things than iRiver itself offers.

BUT ... you know, I love crossfading so when I heard that my iRiver can do that, I had to activate it and it worked - BUT ... after a while, I was playing with ALL THOSE Options (jeez ... that's way too much for a small german like me) and decided that crossfading should be ony available for SHUFFLE-Play and I tried to activate it ... I was listening to a song and pushed the button and then - my iRiver freezes and nothing I could do changed anything. The player itself did shutdown after 10 minutes (the time I did set up for shut down) and whenever tried to re-activate crossfading, the same happens - it's kinda frustrating, you know?

Oh, just to make sure, I set my player to GERMAN language

Can someone please help me or fix that problem?
This task depends upon

Closed by  Steve Bavin (pondlife)
Thursday, 28 September 2006, 16:19 GMT
Reason for closing:  Fixed
Comment by Steve Bavin (pondlife) - Sunday, 24 September 2006, 12:36 GMT
I think the problem occurs when crossfading is in use and all of the time parameters are set to 0. As a workaround/experiment, try setting up a fade-in duration of 1 second and a fade-out duration of 2 then see if that helps.
Comment by Tobi (MickeyKnox) - Sunday, 24 September 2006, 14:16 GMT
OK, thanks for the hint - I will check it later :)
Comment by Tobi (MickeyKnox) - Monday, 25 September 2006, 13:04 GMT
did not work ... it still crashes when I try to activate Crossfading :(
Comment by Steve Bavin (pondlife) - Wednesday, 27 September 2006, 15:30 GMT
Hi Tobi, please can you get a new CVS build and see if you still have this problem. If you do, can you save your settings and attach the .cfg file here.
Comment by Tobi (MickeyKnox) - Wednesday, 27 September 2006, 15:50 GMT
Hey Steve ... downloaded the version from last night and it's still the same ... don't know why. It did work first but after deactivating it while listening to a song (and it's first crash) it does crash all the time I try to reactivate it.
Comment by Steve Bavin (pondlife) - Wednesday, 27 September 2006, 15:51 GMT
Hi Tobi, not last night's version - I only did the fix 20 mins ago ;-). Try the "Bleeding edge build" from here: http://www.rockbox.org/cvs.shtml
Comment by Tobi (MickeyKnox) - Wednesday, 27 September 2006, 15:58 GMT
nope ... crashie crashie
Comment by Steve Bavin (pondlife) - Wednesday, 27 September 2006, 16:15 GMT
Hmm, can you please export your settings and attach the .CFG file here. Also if, you're activating crossfade during playback, try stopping playback first, then activate, then start playback and see if that helps.
Comment by Tobi (MickeyKnox) - Wednesday, 27 September 2006, 16:19 GMT
OK, when my player is "back on track" I will send you the file
Oh, and I always (besides the first time) tried to activate crossfading in stop mode
Comment by Steve Bavin (pondlife) - Thursday, 28 September 2006, 09:31 GMT
Another day - another attempt to fix...;-)

Please get another build from http://www.rockbox.org/cvs.shtml and retest.
Comment by Tobi (MickeyKnox) - Thursday, 28 September 2006, 09:39 GMT
crash

OK, please tell me your settings and I will set up my iriver exactly the same way.
Comment by Steve Bavin (pondlife) - Thursday, 28 September 2006, 09:47 GMT
Not sure that will help, but they're listed below. Before you change anything, please can you go into Manage Settings > Write .cfg file, then press Play and get a copy of the CONFIGxx.CFG file that's produced - then attach it here. The main thing is that this crash is fixed, and I can't reproduce it.

I use:
Crossfade: Track Skip Only
Fade-In Delay: 0s
Fade-In Duration: 1s
Fade-Out Delay: 0s
Fade-Out Duration: 2s

(I also enable the Beep, under Beep Volume: Moderate, as this makes it feel a bit more responsive!)
Comment by Tobi (MickeyKnox) - Thursday, 28 September 2006, 11:07 GMT
OK, here's my config-file ... tell me what's wrong with it
Comment by Steve Bavin (pondlife) - Thursday, 28 September 2006, 15:28 GMT
Thanks Tobi. Nothing wrong with your config, but I think I've fixed the problem now. Please get another build from http://www.rockbox.org/cvs.shtml and retest (hopefully for the last time).
Comment by Tobi (MickeyKnox) - Thursday, 28 September 2006, 16:18 GMT
IT WORKS ... :-)

Loading...