Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category User Interface → Themes
  • Assigned To
    nicolas_p
  • Operating System All players
  • Severity Medium
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by TheKind - 2006-09-24
Last edited by nicolas_p - 2008-07-03

FS#6056 - No text under pictures non displayed...

Hello,
if you preload a picture and don’t show it, you can’t write any text where the image should be when it is shown.

I made a preview of the problem on a wps attached.

Would like to add shadow on album art and other things, but cause of this bug i can’t…

Thanks for fixing that.

Closed by  nicolas_p
2008-07-03 15:37
Reason for closing:  Wont Fix
Additional comments about closing:  

This is a limitation of how WPS rendering is done. It's easy to work around it.

I believe this is a valid report, although it should be verified (by the submitter, preferably) with a clean cvs build.

The problem is unrelated to album art.

Yeah i know that, but i only was saying why i would like it to be fixed :D

I just confirmed this with a clean CVS build simulator and the provided test-case (although for some reason neither the clock nor the background image worked in the simulator, the bug was very much visible).

Definitely valid.

Still Unconfirmed ?

Thanks Jonas

The tracker should _never_ be used to report “bugs” against inofficial builds unless the reporter states that this behaviour is also present in the official build (and he can reproduce it with a current cvs build!) in the first place. The tracker gets abused for support requests and similar pretty much recently which clutters it and degrades its usability. Thus I find it unacceptable to report against inofficial builds.

Just my 2¢.

This bug is on officials releases o_O!

It is unrelated to Album Art!

Screenshot made with Uisimulator with non-modified rockbox:
(Used the wps in the first post)

Any updates?

I have a solution for the problem.
The test WPS clearly shows the problem is solved (although the text under the picture doesn’t reappear instantly), and other WPSs don’t seem to be broken.
I might commit the patch but it needs to be cleaned up a bit first and the issue discussed.

I never committed the patch above because it became outdated and felt a bit clumsy anyway.
I’ve committed something that aims to fix similar problems, but doesn’t quite fix this one.

A solution is to make the disappearing text lines dynamic by adding %?mh<> conditionals in each of them. I know it’s a bit hackish, but I prefer having a hack in a WPS than in the displaying code.

The more general issue is very similar to  FS#6827 : static vs. dynamic. Dynamic things will always overwrite static things. To avoid this, there are several solutions, including forcing the static elements to become dynamic.
However, the best solution is to avoid overlapping, as the WPS code wasn’t meant for it anyway.

Has this been made irrelevant by viewports?

I don’t think viewports have solved the issue, but I’m tempted to close this as “Not a Bug”. It’s more of a limitation of the WPS displaying code. I think allowing overlap would require a complete restructuring of the displaying code and frankly it’s not on my priority list.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing