• Status Closed
  • Percent Complete
  • Task Type Bugs
  • Category User Interface
  • Assigned To No-one
  • Operating System Archos Recorder
  • Severity Medium
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by JazzMan - 2006-09-24
Last edited by pondlife - 2006-10-03

FS#6060 - Variable pitch feature doesn't work

I have an Archos Jukebox Recorder (15Gb and a 20 Gb) ver 1 and the pitch adjustment feature doesn’t work at all.
Could someone look at this problem, seems like an oversight in this particular build. I have tried daily builds all week and none of them work. Althought the ID tag database that was broken with yesterdays build seems to be working with todays build. 6-24-06. As I am a musician the adjustable pitch feature is one of the main reasons that I have been using rockbox since its incepion.

Closed by  bluebrother
2006-10-19 15:23
Reason for closing:  Fixed
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407

According to the reporter this is fixed.

have you cleared the settings?
Also, can you explain “doesn’t work” a bit more? Is the pitch screen working?

IIRC there weren’t any pitch related changes for some time.

What do you mean by “cleared the settings”? I deleted the contents of the .rockbox directory and copied the new firmware into it. Also tried just overwriting the firmware maintaining my custom WPS and CFG files. The on-up and on-down (while playing) key combos continue to do nothing.
Finally, I booted up to Ver 2.5 and the pitch control works as always, but I really like a lot of these other newer features like the tag database which builds in the background (Kudos for that one).
By the way what ever happened to the hot keys that used to give you half speed instantly, now to get to half speed you have to lower the pitch that far, which is very time consuming. I also noticed someone suggesting that rockbox might be able to get the variable pitch feature to be calculated to move in half step intervals as an option, this would help immensely, because searching for the right percentage of pitch and tuning it up to the key your after is fairly tedious.

Rockbox stores its settings in a special block on disk, not in files. You can reset the settings from the “Manage Settings” menu entry. After that you should reboot to make sure Rockbox gets initialized with the default settings. Then you can reload your settings from a configuration file.

Also, try adjusting the pitch from the context menu (there’s an entry “Pitch”) – does this work? It’s possible that with the button rework the hotkeys you mentioned simply aren’t working anymore, but in that case this doesn’t affect the pitch function at all.

OK I reset the settings, still no Pitch function. Next, I can’t seem to find the “pitch” context menu your talking about, where is it?
If the hot keys have been disabled, I find that to be a VERY BAD idea..
I went back and checked some old builds, 8-26-06 it doesn’t work, 2-22-06 version works fine, so the function was changed sometime before August and after February.
Is there somewhere on the Rockbox site that I can access older builds than 8-26-06? I don’t have any versions between there.

I still suspect this to be an issue with the button rework and that simply being forgotten. As I don’t have such a device I cannot test it myself. I’m talking of the wps context menu which can be reached (according to the code and assuming I’m understanding it correctly) by holding play for some time. From that menu you can reach the pitch screen. The manual has a description of that context menu.

This page of the current manual under the WPS section, states the the “on + up or down” should still work to access the pitch menu, There is no pitch control menu on the menu you suggest on my unit, maybe we need someone with an Archos to put his 2 cents in.

I have tried the newest build (Sept 28, 2006)on my Archos Jukebox and the pitch function is not listed on any the menus anywhere. and the pitch function is not called up when I use the hot keys.

Hooray, I downloaded the 20061017 Archos Version and the Pitch function now works using the hot keys “on + up or down”.


Available keyboard shortcuts


Task Details

Task Editing