FS#6066 - Resume playback on startup can cause Rockbox to crash

Attached to Project: Rockbox
Opened by Franz Nieroster (nieroster) - Tuesday, 26 September 2006, 09:53 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System Iriver H100 series
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Accidently I found out that Rockbox crashes on startup if the file it played before shutdown does not exist when starting again.

How did I do it? I connected to the PC via USB and rearranged some direcories including renaming. The file last played was in one of the renamed directories. After disconnecting from the PC I shut down the iRiver player. At the next startup it remembered well what it was playing last time, but could not find the file.

In my opinion this is no reason for an operating system to crash. The correct behaviour would be to ignore the resume playback command an stay in stop position, waiting for the user to select a file to be played.

I use the build from Sep. 23. 2006 but I assume it is still present in today's build.
This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Saturday, 30 September 2006, 10:35 GMT
Reason for closing:  Fixed
Additional comments about closing:  closed upon request.
Comment by Steve Bavin (pondlife) - Friday, 29 September 2006, 07:27 GMT
Hi Franz,

I have tried to reproduce this on my H300, but it seems to work ok. On startup I get a WPS reading "No file!", but pressing stop will return me to the browser.

Please can you retest with a new build, and if it's still crashing, please export your config settings and attach the .CFG file to this report.
Comment by Franz Nieroster (nieroster) - Friday, 29 September 2006, 08:08 GMT
Hi Steve,

you are right, it returns to the filebrowser. But try start playing something else afer this. I bet it crashes.

I noticed that it goes to WPS showing the correct song but the time remains at 0:00, no sound is audible, no more reaction after this => reset necessary

Comment by Steve Bavin (pondlife) - Friday, 29 September 2006, 08:27 GMT
No, it doesn't crash here (with today's build). Please go into Manage Settings > Write .CFG file and press PLAY to save, then attach the CONFIGxX.CFG file here.
Comment by Franz Nieroster (nieroster) - Saturday, 30 September 2006, 08:15 GMT
You're right it doesn't crash anymore with today's build. I cannot even reproduce it with the build from Sept. 23rd anymore. Maybe I've done a reset configuration inbetween.

I think this one can be closed.

Thank you!