Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System iPod 5G
  • Severity Medium
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by agentpyro003 - 2006-09-27
Last edited by bluebrother - 2006-09-28

FS#6079 - Erratic behavior when skipping backwards on FLAC files in iPod 5G

During playback of FLAC files on the 5G, if the Previous button is pressed in the middle of the song (as if you wanted to restart the current song), instead of restarting the song, playback skips ahead a few seconds. Pressing the Previous button near the start of the song (as if you wanted to go to the previous track) works fine, and I was unable to reproduce the error with MP3 files, they seem to be fine.

Closed by  lostlogic
2006-10-29 03:18
Reason for closing:  Duplicate
Additional comments about closing:  

Looks like  FS#5892  is a patch for seeking in FLAC, so I\'m going to close this task; watch that one for updates.

I can confirm this bug on my ipod video using the 061011 cvs firmware.

In addition to the mentioned bugs, if you try and fast forward whilst playing a FLAC to a certain position in the song, it fails to do so (and just continues playing from where it was).

Cheers

I just updated to the latest cvs version to date and the problem still exists.
As it turns out, fast forwarding does not leave you at the same place in the song, it puts you forward about 4 seconds regardless of where you told it to go.. exactly the same as if you try and rewind!

I believe our flac decoder doesn’t support seeking and this is the reason for these behaviors – the forward 4 seconds is because when it tries to seek, it flushes the decoded audio from the buffer before realizing that it can’t perform the seek action.

Oh… well that makes sense then - no actual bug… just not functional.

What are the chances of it being included as functionality in the decoder at some point?

Cheers

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing