Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category User Interface
  • Assigned To No-one
  • Operating System All players
  • Severity Very Low
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by pondlife - 2006-09-29
Last edited by pondlife - 2007-08-02

FS#6087 - Some debug menu options do not allow left to exit

For consistency, it would be good if all options from the menus allowed LEFT to return to the previous menu - most do, the following do not:
- View battery
- View partitions
- View disk info
- View runtime

Also it would be better if Screendump had an Enabled/Disabled submenu, like other settings.

Closed by  pondlife
2007-08-02 10:49
Reason for closing:  Rejected
Additional comments about closing:  

I was obviously in a picky mood when I opened this.

Recently I noticed that e.g. the “View I/O ports” can now be exited with Left. I think the debug menu is special, so it would be better to leave all debug menu screens with Stop only. Right now, the ADC value for the left button won’t get shown anymore as Left leaves the screen.

What I’d like to see is some hierarchy in the debug menu.
Some items are HW specific, some are RB-wide.
It’d be easiest to have something like: (taken from X5 debug menu, might vary for others)

General
-runtime
-battery
-dump ROM
-catch mem access
-screendump

Kernel
-os stack
-audio thread
-dircache
-tagcache

Hardware
-CPU
– CPU freq
-IO
–GPIO
–ADC
-Storage
–HDD info
–partitions
-FM radio
-Flash
-USB-OTG (just thinking ahead…)

ok, well I’ve just commited a fix for bluebrothers problem, as for the actual bug report, the problem is the action contexts being used have a different action for the LEFT button, so STD_CANCEL isnt being triggered, and there is no nice (and target independant) way to fix this.

As for re-ordering the menu options. I think everyone will agree that this menu really isnt important and so it doesnt matter if its not neat.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing