Notice: A non well formed numeric value encountered in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 96 Notice: A non well formed numeric value encountered in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 96 Notice: A non well formed numeric value encountered in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 96 Deprecated: Function create_function() is deprecated in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 104 Deprecated: The each() function is deprecated. This message will be suppressed on further calls in /sites/rockbox.org/flyspray/adodb/adodb.inc.php on line 845 Deprecated: Function create_function() is deprecated in /sites/rockbox.org/flyspray/includes/class.user.php on line 111 FS#6162 : Umuting FM radio does not restore "Force Mono" status

Rockbox

Tasklist

FS#6162 - Umuting FM radio does not restore "Force Mono" status

Attached to Project: Rockbox
Opened by Jason (jasonwea) - Tuesday, 10 October 2006, 20:34 GMT
Task Type Bugs
Category FM Tuner
Status Closed
Assigned To No-one
Operating System Iriver H100 series
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Pressing the play button twice to mute and then unmute the radio results in the radio always being restarted in stereo mode. The "Force Mono" setting does not appear to be checked.

Either quitting the radio and re-entering or toggling the Force Mono option resets the mono state.
This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Monday, 23 October 2006, 19:56 GMT
Reason for closing:  Fixed
Comment by Dominik Riebeling (bluebrother) - Tuesday, 10 October 2006, 22:27 GMT
I can reproduce this. Also, the deemphasis setting isn't preserved after unpausing. As the frequency is set upon unpausing it is correct thus I suspect the tuner is "forgetting" its settings upon RADIO_SLEEP.
I'll have a look into this shortly.

Loading...