Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Codecs
  • Assigned To No-one
  • Operating System Iriver H300 series
  • Severity Medium
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by voltagex - 2006-10-13
Last edited by bluebrother - 2007-08-01

FS#6176 - MP4 playback not working

MP4 playback (at least for this file) doesn’t seem to be working.
Using CVS daily from 13th October 2006 it shows the filename, then “No File!”. An earlier CVS build crashed completely.
MPEG-4 AAC LC, 32.263 secs, 111 kbps, 44100 Hz
Don’t laugh, it’s a friend of mine on the mic :D

(application/octet-stream)    example.m4a (444.9 KiB)
Closed by  bluebrother
2007-08-01 14:31
Reason for closing:  Not a Bug
Additional comments about closing:  

aac files need to be streamable.

Was it encoded with iTunes? Right now, our AAC playback is unreliable for any other encoders, I believe.

Just got a message back from the creator, no it wasn’t.

The file is created by FAAC. It doesn’t play because it isn’t streamable, something Rockbox currently requires. In a streamable file, the metadata (tags and other information about the audio) comes before the audio data.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing