Rockbox

Tasklist

FS#6231 - Song playback

Attached to Project: Rockbox
Opened by John Dennis (jmdennis) - Monday, 23 October 2006, 04:52 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System iPod 4G Color
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

It is quite annoying as I spent the last 2 days changing all my music to .ogg and using your software it will not play through one song with out a break in the song. I have tried all the settings and it is still doing this. I guess I will just have to reload my player with iTunes and reload my software in the morning. It is quite annoying.
This task depends upon

Closed by  Steve Bavin (pondlife)
Monday, 23 October 2006, 08:46 GMT
Reason for closing:  Invalid
Additional comments about closing:  iPod CPU usage issue
Comment by John Dennis (jmdennis) - Monday, 23 October 2006, 05:29 GMT
It is odd but if I have it on a menu then it plays back great. If I have the screen up that shows what song is playing then it will stop and start constantly. I also noticed the latest build will freeze my iPod from booting at all. It does boot but then locks up completely. I have to put it into disk mode and then tranfer over yesterdays files to get it working again.
Comment by Will Robertson (aliask) - Monday, 23 October 2006, 06:17 GMT
This issue is covered in the FAQ, and various other places around the rockbox site.
The issue is that the CPU is being overworked, and OGG is one of the worst codecs for CPU use.
This will be fixed eventually, and it is a known problem, so I think someone should close this bug report.
Comment by John Dennis (jmdennis) - Monday, 23 October 2006, 06:35 GMT
If I use the build from mikeage that has the playlist and tagcache enabled playlist viewed from the 22nd then I can play my songs as normal with out having any issues. Maybe my problem was not having any playlist. There is still an issue with the build for the 23rd but other then that I am back to normal using some one else's build.

Loading...