Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Configuration
  • Assigned To No-one
  • Operating System Iriver H100 series
  • Severity Low
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Alan Morse Davies - 2006-11-09

FS#6309 - H120 optical out setting doesn't stick

With Rockbox in flash on the H120, the setting for optical out is not sticky in the latest builds (8th November), and is set to OFF after each reboot.

Closed by  Dominik Riebeling
2006-11-16 07:39
Reason for closing:  Fixed
Additional comments about closing:  

fixed according to comments. If it\'s still an issue we can reopen this task.

arpi commented on 2006-11-12 18:17

I can confirm that and even after a playback stop and playback start the optical out will revert to OFF.
It goes like this:

After switching on the player the optical out LED is ON (without resume)
After playback start the LED if is OFF
I set the optical out to ON, so now the LED is ON again
After playback stop the LED if remains ON
And after playback start the LED if is OFF

By the way:
How can you determine if Rockbox is in flash?

H140, build 20061108

Davide commented on 2006-11-13 07:23

Ditto: confirmed.

Michael Sevakis commented on 2006-11-13 23:52

I knew about this bug when I comitted the new recording with the intent to fix it quickly. Had to do some target tree moves first before I could do it in the way I wanted. Confirm that is it now fixed (should be, tested it) and I'll close this task.

The optical output should always be on or off per your setting in Playback|Optical Output. You'll still get the dim output if using digital in as the source with the output off. Nothing can be done there.

EDIT: Of course after reading the reported problem (been really scattered around lately :P) the bug that was part of the commit shoudn't have anything at all to do with flashed fw or not. My repair of the digital out behavior was for a known issue of it being left in the wrong state after a recording session but if this fixes the reported problem too all the better.

Alan Morse Davies commented on 2006-11-14 15:55

Confirmed, fixed for me.

Davide commented on 2006-11-14 22:32

I checked this visually only, but seems to be fixed here as well.
I don't access to an optical in this minute, but I presume signal is passing properly.
At the very least the light stays on as it should. :-)

Michael Sevakis commented on 2006-11-14 22:39

I checked it before committing and the output is correct however I need to mod the cables so I can have two plugged in at once. They're too close together to check a direct digital feedthrough.

Michael Sevakis commented on 2006-11-15 01:13

Maybe I should consider this bug fixed?

arpi commented on 2006-11-16 07:11

Yes, from my part it is now fixed.
Tried, working.
Thank you.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing