Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by jspenguin - 2006-11-10
Last edited by Marc_Guay - 2008-03-30

FS#6314 - Reverse stereo on resume with WAV

When playing a stereo WAV, if playback is stopped and then resumed, the stereo channels are reversed until a seek is performed or the song is changed.

Closed by  Marc_Guay
2008-03-30 22:59
Reason for closing:  Out of Date
Additional comments about closing:  

The silence is deafening. This bug was never replicated.

nls commented on 2006-11-10 22:47

On which model of player is this happening and how old is your rockbox build (and is it an official build)?

Sorry… it's h120, 20061012, daily build.

petur commented on 2006-11-15 22:16

Works fine here with current CVS (20061115) on a h340 (which should be almost identical in terms of code)

I used STOP, not pause…

Can you check again please?

petur commented on 2006-12-09 18:39

bug to be closed if OP doesn't confirm

MikeS commented on 2006-12-10 00:27

It's entirely convievable for the buffer to get out of phase by 2 bytes which would reverse channels. Will investigate asap.

petur commented on 2007-07-31 07:42

Did you check this, Mike?

MikeS commented on 2007-07-31 11:11

I'm sitting here trying to do it with a test file and cannot.

D-Boy commented on 2007-08-14 12:00

I have had a similar experience with my r13390-070726 on my ipod Nano 1st gen. I was playing two similar files different encoding, classical piece Pachelbel's Canon in D, one was an mp3 and one was a FLAC file. I was doing a blind test to compare my VBR encoding and some reason one time I noticed that the that the audio channels were reversed so I took off my headphones and checked (it was impossible too because the cable is only on the left side). I then went to the channel settings and found something really weird, if I go to stereo the channels seem reversed… I then go to Mono Right and I hear the correct right, and Mono Left and I hear the correct left but when I go to stereo, what I heard on Mono Right was on left and Mono Left on right, hence reversed. This happened after I pressed next a few times with only those 2 tracks to mix which one I wanted to hear. I then stopped the music and restarted one of the files and the channels are correct again. I'll post again when I have reproduced the issue.

I cannot use any newer build for my nano because they are currently broken.

Is this still an issue?

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing