• Status Closed
  • Percent Complete
  • Task Type Bugs
  • Category Games
  • Assigned To No-one
  • Operating System iPod Nano
  • Severity Low
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Dwyloc - 2006-11-15
Last edited by dionoea - 2007-10-16

FS#6334 - Star plugin locks up device after selecting play.

The Star plugin locks up my player when I select play and a reboot is required to exit the plugin.

Tested with the current ipod nano CVS build from 15 Nov 17:29.

steps to reproduce.

1. reboot ipod nano and clear config settings on bootup.
2. Open the menu and select star plugin from the Browse plugins menu.
3. Press select to start playing
At this stage the game status bar will be displayed and the player will lockup and require a reboot to exit.

Closed by  dionoea
2007-10-16 08:05
Reason for closing:  Fixed

It also does it on my Nano. I saw an iPod Video and there is a fading. Someone should do a patch to put off this fading on the Nano.

Same problem here.

Running r13725-070627
iPod Nano 2GB.

After selecting Play my iPod was frozen on the menu and disconcertingly heating up. I could hear no music (wasn't playing any but I read in another bug report that there was music playing although the plugin was frozen).

I had trouble rebooting it too managed to get it rebooted after a few hours.

Could someone confirm that this still happens on newer builds? Does it also happen in the simulator? (I only have an iPod Video and an archos Recorder v1 so I'm unable to test on Nano. I'll have a look at the sim version later today)

Yes it still happens with today's build, on my iPod nano, if memory servers correctly one or more other target also had the problem.

So the issue is worked round in SVN by disabling the screen translation effect on the other effected targets but for some reason it has not been disabled for the nano.

Works fine in the nano simulator :/

The only thing which must be different on the real target is the rb→lcd_update_rect call. Could you try adding a bunch of { int fd = rb→open( "/star_debug.txt", O_CREAT|O_WRONLY|O_APPEND ); rb→fdprintf( fd, FILE " %s %d: %d %d %d %d %d\n", func, LINE, center_x, x, center_y, y, step ); rb→close( fd ); } in the star_transition_update function, lines 539 to 544 and paste the contents of the star_debug.txt file if it looks interesting ? (I'm guessing that the x or y values must somehow overflow an authorised range … although it'd be weird that this would cause a crash)

Douglas, could you give that a try?

Sadly I don't have access to by build environment at the moment but I believe that amiconn worked out what the problem is if you look at the IRC logs at 21:46 as the problem seems to effect a number of other targets as well.

I can have a look at it next weekend if its still required when I will hopefully have time to setup my new laptop with VMWare.

Thanks for the hint. I've committed a fix (if I understand amiconn's diagnosis correctly). I'd appreciate if you could test a dev build.

Yes that seems to have fixed it on my nano thanks.

Cool. I'll close the task.


Available keyboard shortcuts


Task Details

Task Editing