Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System iPod 5G
  • Severity High
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by CCNaru - 2006-11-16

FS#6344 - 00030F18

The data abort # is 00030F18

It seems that it crashes when rockbox has Korean filename. first crashed on 11/15/06 build… I want old settings back :<

and one more thing, on the playing screen Korean is broken - the language shows properly just on the menu list.

I have XP Pro Kor in this laptop and 5g gen ipod video.

Closed by  pondlife
2006-11-17 14:26
Reason for closing:  Fixed
Additional comments about closing:  

Probably caused by the APE tag removal problem, now fixed.

one more thing, I tried putting 10/17/06 build and there aren’t anymore of data aborts, just to let you all know.

have you
- reset your settings?
- reinstalled a cvs build?
- what exactly do you perform right before the crash? Does it crash immediately upon startup?

- reset your settings? - yes, cleared everything, went to original apple ipod firmware then back, still fails.
- reinstalled a cvs build? - uhm no idea buut i did extract everything onto the root ipod folder.
- what exactly do you perform right before the crash? Does it crash immediately upon startup? - it seems to crash 4-5 seconds after i select the file. i didnt perform anything, per say, except selected the song.

- you mean “reboot” or clearing the settings through the “Clear Settings” menu by cleared? Also, powering up the ipod with hold enabled also clears the settings (the screen should say “cleared” while booting)
- does this crash always appear on a specific file?

- both.
- yes. actually, i found 10~20 songs that didn’t crash even if it had korean filename, but they’re from a same rip from the same album.

Hi Eric,

Try a new Bleeding Edge build from http://www.rockbox.org/cvs.shtml. This fixes a data abort problem if a file contains APE tags.

Please report back with this too.

tried CVS build and there wasn’t any data aborts.

I guess I don’t know what i’m doing… never thought there’d be APE tags on mp3s though

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing