Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System iPod 5G
  • Severity Low
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by jacobts - 2006-11-29
Last edited by Marc_Guay - 2008-03-30

FS#6395 - ipod video scroll and screen locks up when playing music

when i am listening to music for about ten minutes with rockbox, the screen and click wheel will lock up but, the music will still keep playing.

Closed by  Marc_Guay
2008-03-30 23:28
Reason for closing:  Out of Date
Additional comments about closing:  

Presumably this has been fixed given the lack of recent uproar and silence on the part of previous commentors.

I can confirm this bug, I am running on a 5.5G 30 Gb iPod.

Doesn't happen on iPod 5G first gen though.

If you adjust the volume, it "wakes up".

ok, i have an ipod video 5g first gen too, it happened to me but, i uninstalled rockbox cause it wastes too much battery, when the make an official release i will re install

Hi Jacob,
Well I think you don't really need to uninstall RockBox, what I recommend you is, as I do, install iPodLoader 2 (from iPodLinux) so that you can start either RockBox or Apple firmware when you turn on your iPod. Then just keep updating RockBox and try it to see if the problem get solved while still being able to use Apple's FW.

yeah, i had that but it wouldnt let me boot into apple os so i just un installed it

Hi again,
iPod Loader 2 is still experimental and has some bugs, such as the autoconfiguration. To prevent this you can use config files. I have made one that can load RockBox and Apple firmware (I have test it) with no problems. All you need to do is reinstall iPodLoader 2 and RockBox while being in the Apple FW (not diskmode) and then copy the attached file in the root of your iPod drive. Then restart your iPod (it must be unplugged first, even charger), and it should display the correct choices.

zqad commented on 2007-01-09 11:41

I can confirm this, but it only triggers when I have the key-lock turned on. The playback continues, but I can't do anything but reboot it.

It could work with the joggle-with-volume-to-make-it-work-thing that James suggested, but with the keylock on this does not work; probably because rockbox never registers that I've turned the keylock off.

iPod Video 5.5G 30GB

This seems to be a very varied problem!

My volume-thing seems to work even after unlocking, although maybe this is dependent on the build??

zqad commented on 2007-01-09 14:42

The problem exists with both 20061217 and 20070109. I have, however, found a remedy. I simply changed from rockbox_default to a theme without VU-meters (geek-dark in this case), and it seems to work out great. I'll post again if it fails later :)

I also managed to hang it with hold off, so disregard the comment about that I made earlier.

Sounds like there's not enough CPU to go around. As well as using a simpler WPS, you can try disabling any EQ or crossfeed. Hopefully this will be much improved by use of the COP in the near future.

I've had this problem with my ipod video since I started using rockbox many months ago. Has anyone actually confirmed that it's a problem with VU meters? I honestly can't pin it down to anything. Happens randomly and inconsistently across formats ogg/mp3. I always thought it was a bug in the hard drive access or something to that effect locked it up.

redic commented on 2007-09-09 12:01

Hi
i can confirm this bag on iPod Video 30GB r14655 2007-09-09
i have no WPS, no EQ, no crossfeed, and the bug is still here
the screen and wheel freeze, but when i touch the wheel the screen lightned up ut still freeze

Hi
I can confirm this bug also on an iPod Video 60GB r14655
The same problems as told by M. Redozubov Anton.
Screen and Wheel freezes, music keeps playing and the screen lights up when i touch the wheel but everything else wont work. Resetting my Ipod is the only way to get it up and running agian.

Just an update with some experiments. I created my own WPS with no VU meters and my ipod has not locked up while playing since then. My iPod would formerly lock up with music playing and with control multiple times a day. I never looked at the meters anyway so I am much more happy with rockbox ever since. So my testing would seem to support zpad.

Is this still a problem with a current build?

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing