Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category User Interface → Font/charset
  • Assigned To No-one
  • Operating System Iriver H300 series
  • Severity Low
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Nils Wallménius - 2006-11-29

FS#6397 - Selecting a big font while "show path" is enabled craches in the font browser.

Steps to reproduce.
0. Reset settings (optional)
1. Set show path to current directory
2. select ter-32n from the font browser in the menu
3. press left to back out from the font browser

if “show path” is off it works fine.

Closed by  Peter D'Hoye
2006-12-09 10:02
Reason for closing:  Accepted
Mark Arigo commented on 2006-11-29 18:45

This is a bug in gui_list_draw. If list titles are displayed and the screen can only display one line, it deadlocks because it can't draw the list. You'll see it on targets small screens including lcd remotes regardless of whether the remote is plugged in.

I've attached a quick patch.

Nils Wallménius commented on 2006-11-29 19:05

The patch fixes the issue for me.

Peter D'Hoye commented on 2006-12-08 22:39

I've taken the liberty of moving the define into a function so we don't waste bytes.
Also did some code policing. Tested and fixes the issue too.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing