Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Recording
  • Assigned To No-one
  • Operating System SW-codec
  • Severity Low
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Peter D'Hoye - 2006-12-03

FS#6409 - Crash when stopping recording

Had a crash at the end of a recording.
After recording almost 100 minutes I pressed stop and after a short pauze it gave me (if I remember correctly) I04 at 00000002. It turned out it had saved the file ok, including the header, so no problem there.
Could be I pressed stop more than once but I'm _unable_ to reproduce.

Closed by  Peter D'Hoye
2007-02-26 23:52
Reason for closing:  Fixed
Additional comments about closing:  

Seems to have been fixed by the recent changes

Peter D'Hoye commented on 2006-12-08 18:06

Still not solved in CVS 2006-12-08 (around 1:00)

Last attempt during recording, after a mere 10 seconds pressing stop and again stop during flushing made my h340 require help from a paperclip :(

At this moment recording doesn't even want to start again :(

Peter D'Hoye commented on 2006-12-08 18:13

just found a way to make it freeze:

from the rec screen:
- pres rec to start recording
- press stop
- press rec again while still flushing
*bingo*

Peter D'Hoye commented on 2006-12-09 16:54

dang - not reproducable anymore :( - now it just ends up not updating the screen the way it should but still respond to start/stop

also, a logf build works the way it should, so I *really* think we're looking at a timing/race condition hereā€¦.

Michael Sevakis commented on 2006-12-09 23:35

I just plain can't get it to do it in either way (never could on x5 either when mashing buttons). As far as a race condition, that shouldn't be possible at all. The next command should wait for the stop to finish and the second (stop/pause/etc.) rejected because it's already stopped. I'll metion here again that the screen should freeze momentarily on the second press but should start updating again once the stop is finished. The pcmrec thread *always* receives the messages and incorrect commands are filtered by pcmrec after dequeue. The posting thread just waits for processing.

Some things are repeated here from the forum response just for the record. :)

Will keep thinking hard and may see ways to simplify things.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing