Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Settings
  • Assigned To No-one
  • Operating System iPod Mini
  • Severity Medium
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by The Doctor What - 2006-12-13

FS#6432 - iPod: Resets too easily!

What happens:

When plugging in or unplugging my ipod, if the hold switch is on, it looses all my settings.

What I expect to happen:

It shouldn't loose my settings unless I perform an explicit action.

Suggestions:

Since it isn't really possible to detect that the iPod was just unplugged, I would argue that the hold switch isn't a good way to send a reset.  One suggestion from IRC was to have the hold switch cause a "do you want to reset" dialog to appear on startup.  The dialog would temporarily reset settings until the user makes a decision.
Another solution:  Rockbox could look for a default.cfg file, when resetting, and use those settings.  This way I would always have the settings I have worked on!

I and a friend both have problems with this feature. My friend didn’t realize why the settings kept resetting. He just assumed Rockbox was broken. When I told him about this feature, he decided his best option was to just not use any settings.

Ciao!

Closed by  Nils Wallménius
2006-12-13 13:29
Reason for closing:  Duplicate
Additional comments about closing:  

As this is not a bug report, but rather a request to change behaviour it is a duplicate of  FS#5709 

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing