Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Battery/Charging
  • Assigned To No-one
  • Operating System iPod 4G Grayscale
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Version 3.0
  • Due Date Undecided
  • Votes 1
  • Private
Attached to Project: Rockbox
Opened by Joel Wiegman - 2006-12-21
Last edited by Jonathan Gordon - 2008-08-17

FS#6465 - "Idle Poweroff" while charging causes infinite reboot loop

I have turned the “Idle Poweroff” to “2 min” in the “General Settings > System” menu. Now if I plug my iPod in to charge the battery, the device reboots every 2 minutes (powers off, detects it’s plugged in for charging, then boots back up). I’m guessing this is a known issue but I couldn’t find a patch or existing defect…

Closed by  Jonathan Gordon
2008-08-17 14:44
Reason for closing:  Fixed
Additional comments about closing:  

this should be fixed for all targets except the 3rd gen ipod which doesnt have usb detection code.

Paul Louden commented on 2006-12-22 02:56

If you’re charging from the USB port on a PC, it should reboot into disk mode.

If you’re charging from a wall adapter, it should continually reboot.

You say it’s booting into Rockbox, waiting two minutes, and then rebooting again. Are you using an official build?

Joel Wiegman commented on 2006-12-26 15:58

I’m charging from a wall adapter, using a build from 12-11-2006, and it reboots every 2 minutes due to the “Idle Poweroff” being set to 2 minutes. You mentioned the device should continually reboot… so this is expected behavior?

Tom Ross commented on 2007-02-12 22:00

Can you try to reproduce this with the latest SVN? Wall chargers and USB chargers are now treated differently and it’s possible your issue may no longer occur.

Joel Wiegman commented on 2007-02-14 18:42

Updated to a 2/14/07 build. Still continually re-boots when plugged into a wall charger. My “Idle Poweroff” setting was set to 2 minutes and the device reboots every 2 minutes.

Jason commented on 2007-05-30 16:01

I too am experiencing this bug. What is irritating is if I have my headphones plugged in, it resumes when it powers back up. Therefore I have to unplug my headphones if I’m going to leave it paused for a while.

Suggestion: Can we have it ignore auto-poweroff on idle settings if the power source is wall and not battery?

Jason commented on 2007-06-06 16:00

Also wanted to add that I have to disable “Resume Playback On Startup” option. Otherwise I will be sitting at work with my player paused and suddenly it will start blaring through my earphones because it booted up again.

It’s irritating, but not a major flaw. It just nullifies the resume playback option for me.

Jason commented on 2007-07-26 19:12

Will this be fixed anytime soon? If not, is there any documentation on getting started with understanding the source code?

Jan Seeger commented on 2007-09-13 16:34

This seems fixed now with the newest build (r14680M-070913) on the iPod Video 60 GB. Cheers!

Joel Wiegman commented on 2007-10-03 15:26

This defect was created for the iPod 4G grayscale (see the “Player type” above). I updated my firmware with todays build and this defect has NOT been fixed. Please disregard jeeger’s comment.

Jason commented on 2007-10-08 16:33

I am no longer experiencing this issue with the latest rockbox for my Nano 1st Gen.

Federico F commented on 2008-01-03 19:40

I have a 4G iPod and I have this problem too, anyone have an idea on how fix it? Thaks

Ian Weller commented on 2008-01-13 23:51

i am having this same problem, same ipod, latest build.

i don’t have a wall charger, but i use an iHome that’s about 2 years old. when i view I/O ports in the debug menu that i probably shouldn’t be playing around in, GPIO_C changes from FE to FA when i dock the ipod in, and changes back when i remove it. can somebody else see if they get the same thing when they plug it into a wall charger?

Daniel Phillips commented on 2008-02-24 07:31

I am having this problem with latest build (r16387-080223) using ipod 3G. If the player is charging it will power down according to idle poweroff and then immediately reboot. Without external power, idle poweroff works without a problem. If resume is set, it will resume playing.

Daniel Phillips commented on 2008-03-10 10:08

Just to update, I tried 16601 today with the same problem on a 3g.

Markian Zadony commented on 2008-03-14 17:40

I want to confirm that this is happening on my 5G-Video 30GB with 16652M, however it started when I upgraded to this build. The previous build I had–not sure exactly what version, but was from I believe 2/18/08–did NOT have this problem, so something got introduced in the past ~3 1/2 weeks.

Also, none of the icons indicate that the iPod is charging when using a wall adapter. Looks like it doesn’t know that it’s charging (when it actually is), then powers down and reboots every 3 minutes (my setting).

I’m concerned that the number of power cycles could be detrimental to the hardware or if the battery is getting overcharged… Is the mechanism that prevents battery overcharging hardware-based (no problem) or software-based (big problem)?

Dmitry Gromov commented on 2008-03-25 06:57

I can confirm constant reboots and no charging indicator on iPod 5G Video 30Gb with r16655.

Dmitry Gromov commented on 2008-03-25 07:28

Just installed build r16791 and both problems idle time reboots and charging indicator) are solved!

Ian Weller commented on 2008-03-25 20:56

bug fixed with r16806, iPod 4G grayscale 20 GB. charging indicator does display.

Daniel Phillips commented on 2008-03-26 10:54

….. still the same on the 3G grayscale 20GB

Markian Zadony commented on 2008-03-26 14:50

Bug fixed on my iPod 5G Video 30GB… Using r16812. Thanx!

Daniel Phillips commented on 2008-03-30 22:35

I can confirm the problem still exists on r16893 with 3G grayscale

bob commented on 2008-04-21 04:04

I’m having this problem with firmware r17194 on a 4g iPod Color/Photo 30G.
Thanks

Yoshihisa Uchida commented on 2008-07-28 13:40

In Rockbox of the latest version (svn 18139), I think this problem to be corrected.
I confirmed this problem did not occur by iPod Photo 30GB.

Daniel Phillips commented on 2008-07-28 17:44

Still looping on r18139 with 3G grayscale 20GB

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing