Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System Iriver H100 series
  • Severity Low
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by michael.conner - 2006-12-22
Last edited by Marc_Guay - 2008-03-30

FS#6468 - popping sound on playback begin w/crossfeed on

I get a brief popping sound (1/10 second perhaps?) when beginning a playlist if I have crossfeed enabled on my h120.
Turning off crossfeed seems to stop it from happening. Switching between songs in the playlist doesn’t seem to cause it. It’s more frequently in the right channel than in the left channel, although I’ve heard it in the left ear before.

Closed by  Marc_Guay
2008-03-30 23:11
Reason for closing:  Out of Date
Additional comments about closing:  

Again, the silence is deafening. If someone else comes across this the task can be re-opened, but in the meantime I see no harm in closing it.

Is this beginning a .m3u playlist, a dynamic one, or both?
As well, what is your crossfeed setting set to when this happens? Does it happen with all possible crossfeed settings, or just certain ones?
Do you have any other settings set different from default (or, better yet, can you reproduce this bug with JUST default settings + crossfeed, so that we know it’s not happening from a combination of settings, rather htan just one)?
And, of course, I assume you’re using the very most recent CVS build?

This is either beginning a dynamic playlist – either by toggling right on the first file in a directory, or by hitting NAVI and Playlist–>Insert – or beginning an M3U playlist. It seems to be dependent on playback of another playlist having been stopped and another one having been started. It doesn’t happen if resume is set to off and I just start playback when starting the machine. It also doesn’t happen if I resume playback of a playlist that I’ve just stopped.

My crossfeed settings are set to the default settings – I’ve not experimented with other settings. The only non-default setting I have in sound settings is that dithering is set to on. I turned dithering off and it still happens.

It does this with CVS 061214 and 061221-2337.

It happens almost every single time I stop playback while playing an MP3 playlist and beginning one that is in Ogg Vorbis format. Going from an Ogg playlist to an MP3 playlist does not cause it.

Hi Michael,

Do you mean crossfade, or crossfeed?

Is this still a problem?

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing