Rockbox

Tasklist

FS#648 - bmp2rb.exe does not work correctly

Attached to Project: Rockbox
Opened by J Os (meltedguy) - Friday, 20 December 2002, 14:07 GMT
Last edited by Daniel Stenberg (bagder) - Friday, 05 December 2003, 09:29 GMT
Task Type Bugs
Category
Status Closed
Assigned To Daniel Stenberg (bagder)
Operating System
Severity Medium
Priority High
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

i create a bitmap file 8 bit depth with a size of 5 pixels
by 5 pixels yet when input the file i get an error saying
that its 1024 bit depth, and the bitmap i created is not
1024 bit depth, i even tried inputing a bitmap with only 1
bit depth and the program said it was 256 bit depth i
then tried a 4 bit depth bitmap and the program said
1048 depth.
here is the error

C:\rbuild\tools>bmp2rb -i freak -a freak.bmp
error - Bitmap uses more than 8 bit depth, got 1024

the bitmap file is attached
This task depends upon

Closed by  Daniel Stenberg (bagder)
Friday, 05 December 2003, 09:29 GMT
Reason for closing:  Works For Me
Comment by Daniel Stenberg (bagder) - Thursday, 09 January 2003, 15:49 GMT

This works fine when I build and run on Linux.

I seriously suspect that the struct align stuff at line 41
in bmp2rb.c is not properly done for your compiler. Whatever
compiler it is (which you didn't mention).
Comment by Anonymous Submitter - Saturday, 19 April 2003, 11:45 GMT

this bug is fixed with patch 708098

Loading...