Rockbox

Tasklist

FS#6534 - No AGC option in Recording Settings menu

Attached to Project: Rockbox
Opened by Rob (sonicsavage) - Saturday, 13 January 2007, 11:29 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System iAudio X5
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Me again, sorry.

When setting up my X5 for trial recordings this morning I desperately wanted to try out the AGC options, but they don't appear on the menu at all. I'm using the daily build dated 12th Jan 07 for the X5.

Is that because something went astray during my installation, or has it been removed as part of a fix at some point.

Many thanks for your help. And thanks for making your excellent OS available.

Cheers. Rob.
This task depends upon

Closed by  Nils Wallménius (nls)
Tuesday, 16 January 2007, 20:50 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  This feature is not included in the x5 build because it is not very useful with the gain control in the player. As MikeS posted.
Comment by Dominik Riebeling (bluebrother) - Saturday, 13 January 2007, 12:42 GMT
Currently the x5 builds don't have AGC enabled. add

#define HAVE_AGC
to firmware/export/config-iaudiox5.h

and recompile. Adding this to svn should be done by someone who can test on a x5.
Comment by Michael Sevakis (MikeS) - Saturday, 13 January 2007, 21:32 GMT
I wouldn't even bother. The tlv320 audio codec in the x5 hardly has enough volume resolution or range to make it worth it esp. with the mic which is either 0db or 20db gain. If a DSP solution were put in place in recording itself where the hardware isn't sufficient, then it would be usable.

Loading...