Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Battery/Charging
  • Assigned To No-one
  • Operating System iriver H10
  • Severity Medium
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Udi Meiri - 2007-01-16

FS#6544 - battery drains when H10 is off

After using the H10 for a while, shutting it down and leaving it off for a day or two, it no longer wants to power back up because the battery is too low (you can see the iriver logo with the “low battery” icon and then it turns off).

Work around: Take the battery out after shutting down. There’s an audible click in my earphones when I do this.

Rockbox used to fully shut down with the click, but at some point it seems to have stopped fully shutting down (the processor is still on?).

Closed by  Barry Wardell
2007-03-18 16:53
Reason for closing:  Fixed
Additional comments about closing:  

Looks like this no longer happens. Possibly fixed by recent changes to power_off()

Tom Ross commented on 2007-01-19 23:10

Any idea on when the click stopped occurring?

Udi Meiri commented on 2007-01-20 18:58

I'm not sure when the change was made. Around 3-6 months ago.
Is the CVS changelog available anywhere?

Tom Ross commented on 2007-01-20 19:42

http://www.rockbox.org/since25.html

That has all of the changes made since 2.5 was released. You're probably looking for a change in a file in /firmware/target/arm/iriver/h10

Barry Wardell commented on 2007-01-20 21:22

Are you sure the H10 is fully powered off?

I've experienced a problem from time to time where the iriver bootloader (ie. the one that shows the blue iriver screen when you power on, not part of rockbox) crashes. It's hard to tell it has crashed as the backlight is off, but you can usually just about make the image out on the screen. In this case, I think your H10 is still powered on and draining power.

The problem is that this can happen even if you power Rockbox off and leave the hold switch on. Accidentally pushing power still turns the device on and loads the iriver bootloader. It detects hold being on, then tries to shut down. And that's when the crash occurs.

If that's the cause of your problem, then there's not much we can do about it until someone decides to write a replacement for iriver's bootloader (which probably won't be soon).

Udi Meiri commented on 2007-01-20 22:02

Tom: The list is empty (probably because of the recent switch to SVN).
"svn log FILENAME" worked for me.

Barry:
Here's what usually happens:
I use the H10 primarily in my car. After I park, I turn it off and then move the hold switch to "on" (old habit).
I leave the player in the car, and when I turn it back on that same evening or the next morning, the iriver bootloader complains of a low battery and turns itself off.
This didn't use to happen on the original iriver firmware.

Udi Meiri commented on 2007-03-18 12:46

Update: Shortly after I reported this bug, I could no longer reproduce it (Murphy's Law?).
Plus, I see that Barry Wardell recently added a check to verify that the H10 power off function doesn't return before powering down. (r12801)

You can close this bug.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing