Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Operating System/Drivers
  • Assigned To No-one
  • Operating System iAudio X5
  • Severity Low
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Malcohol - 2007-01-29
Last edited by Marc_Guay - 2008-07-08

FS#6590 - X5 Rockbox USB mode not working

Rockbox’s USB mode on my X5 no-longer works (at least when connecting to GNU/Linux machines).

General details:
* I’m using a build from the 26th of January (but problem started a few weeks ago)
* The original firmware’s USB mode is still working.
* Problem observable on two seperate computers with Linux 2.6.17 kernels or later.
* If necessary, I can try the device on machines with other OSs.

Plugging in the USB cable while Rockbox booted:
* The USB picture appears on the player
* Computer seems unaware that a device has been connected.
* No console messages are generated on the computer
* Attaching other USB devices (e.g. a USB key) works and does cause console
messages to appear.

Thanks for any help.

Closed by  Marc_Guay
2008-07-08 04:32
Reason for closing:  Fixed
Additional comments about closing:  

See comments. If anyone can reproduce please reopen and mark Due In Version 3.0.

Please test on different OS / PCs. As the USB screen appears on the device (and USB is handled in hardware) I assume this to be a hardware issue – perhaps the cable is broken and works only in some cases. As I don't know your setup there might be also an issue with a usb hub.

OK. I've done some more tests.

I can confirm that the behaviour is exactly the same when connecting to Windows.
If rockbox is booted, the computer doesn't pick up on the connection. If the
player is off then it does.

The behaviour is the same with:
* two different USB cables.
* a subpack and a dock.
* a hub and no hub.

I'll try an old build of rockbox tonight to see if the problem is a recent software
change. I've found one from 2006-12-30 but I can't remember when the problem began,
so this may not be old enough. What's a good way of obtaining an older build?

the daily builds page (http://www.rockbox.org/daily.shtml) holds the dailies for the last four weeks, for older ones you need to pull it from svn.

Another test: The build from 2006-12-30 does not fix the problem.
I'll try to get an older build off svn.

Couldn't get svn to go through my proxy, so I poked around my Trash folder
and found a build from 2006-10-12. Lo! It works!

Something must have broken between 2006-10-12 and 2006-12-30. If anyone
wants me to perform more specific tests, that's cool, but you'll have to
provide somewhere I can easily download builds.

Here is the problem. The file /firmware/target/coldfire/iaudio/x5/usb-x5.c
was changed on Wed Oct 18 2006:

http://svn.rockbox.org/viewvc.cgi?view=rev&revision=11261

Although the cvs log was "iAudio X5: USB mode working
again", it has exactly the opposite effect on my X5. If I compile
the most recent source as is, the USB mode does not work. If I
change usb-x5.c to the version prior to the above revision, then
it works fine.

As noted at this forum thread:

http://forums.rockbox.org/index.php?topic=8595.0

the bug does not effect everyone.

In case it's important, I have a X5L 30G.

Ooh! I've just remembered that I have the unsupported dual
boot firmware installed. I'll test with the actual Rockbox
firmware this weekend.

I've installed the official Rockbox bootloader (from a build from late January).
The problem remains.

Correction, the bootloader was from a source download.

dogo commented on 2007-08-01 13:46

–Tracker Cleanup Week–

Plugging in the USB cable while Rockbox booted:
>* The USB picture appears on the player
>* Computer seems unaware that a device has been connected.
>* No console messages are generated on the computer
>* Attaching other USB devices (e.g. a USB key) works and does cause console
>messages to appear.

Problem persists in daily build from end of july 2007 (maybe 29th?, don't remember exactly)
PLEASE fix this first ;-)

Works here on Ubuntu Hardy, kernel 2.6.24 .
Can anyone verify that this bug still exists?

goffa commented on 2008-07-08 04:30

Tried on 3 archlinux boxes running kernel 2.6.25. No problems here either. I'd say case closed.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing