• Status Closed
  • Percent Complete
  • Task Type Bugs
  • Category User Interface → Themes
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by PauloHK - 2007-02-09
Last edited by jdgordon - 2007-02-12

FS#6640 - WPS bugs on iPod video 5G

1) On “Browse Themes”, the WPS themes are not loading correctly. Just the backdrop and fonts are loaded, but the old icons, etc, remains from the previous one. It seems like they dont find the wps images folder and .wps file.

2) I realized that when saving config on “Write cfg files”, the WPS text info is saved on wrong directory: wps: /.rockbox/wps//.rockbox/WPS/blablabla.wps

Build version 2007/02/08.

Closed by  jdgordon
2007-02-12 07:50
Reason for closing:  Fixed
2008-04-05: A request to reopen the task has been made. Reason for request: I tried to post this same exact problem almost but someone closed it ><. I don't understand what I have to change / correct. I keep re-reading it over and over and I still don't understand. None of my WPS are working for my 5g iPod either. You clearly say on the bottom "if it happens again, repost it." I don't know why it was closed. >< Examples of themes that work: Supermario & the zelda one (strangly enough). What doesn't work: Avant Blue & Orange. I've tried reinstalling EVERYTHING, but it doesn't work. What happend?

does the wps load correctly after a reboot?
what is the wps: line in the theme you are trying to load?
does this happen for every theme?

does the wps load correctly after a reboot?

A: No, they don’t load correctly after reboot. It’s a total confusion. Sometimes they load the backdrops keeping the previous fonts, and sometimes kepping the previous fonts and icons.

“what is the wps: line in the theme you are trying to load?”

A: Sorry, but I don’t understand this question. Please explain better, cause my english is not enough. What line you’re saying? I loading themes on “Browse Themes”, and on the line is the name of the theme I’m trying to load.

does this happen for every theme?

A The uniCatcher, boxes and rockbox default are loading correctly. iCatcher, Rockboxed and other themes (phk1, phk2, etc.) not.

Just one more info: Now, the old Database are not recognized anymore. I got a message “database is not ready”.

connect your ipod to the computer, goto the .rockbox/themes folder and open one of the .cfgs’ that doesnt work correctly.. find the line that starts wps: and paste the whole line here please…

also try copying your whole .rockbox file somehwere and extract the file onto your player again..

Hi, I checked this before, and they are all correct:

wps: /.rockbox/wps/phk1.wps

wps: /.rockbox/wps/Rockboxed.wps

I did a wipe cleaning and extract the current and fonts. I realized that iCatcher had new fonts.

uniCatcher, boxes and rockbox default are loading correctly. Rockboxed just load the WPS backimage and icons, but keeps the previous fonts. My themes (phk1, 2 etc…)are not loading, just the backdrops.

Ohh, the Rockboxed.cfg file got no fonts command. That’s why they keep the previous fonts.

But my themes are all correct. Anything was changed in wps, cause allways worked before.

Ahh, this is not new, but the standard Rockbox themes have not background/fonts colours command in the cfg files, so they allways keep the previous ones too.

noone else has mentioned this bug, so im going to assume its the theme/wps itself.. can you attack a zip with the .cfg adn the wps and its needed files please?

They are In the ipod wps 5G gallery: phk1, phk2, phk3, phkZ

Not just my themes, but another ones too. I had the same bugs with Brushed Metal.

OK… i just realsied the problem.. firstly, the line you pasted is not whats in the theme file… your theme (and all the broken ones) have WPS not wps in the foldername which is wrong!

Yes, I realized this before and renamed on my iPod, but still got the bugs.

oh? damn… well please try the build that is currently being built… im compilin the 5g sim so i can see whats happening…

Sorry, maybe you’re right. I tried rename again to wps and now just worked! I’ll make more tests with another themes to confirm.

ok, i tried your phk1 wps in the sim, and as far as i can tell its working fine… lemme know if it is so i can close this

All themes I tested are loading OK now. You are right: Is the WPS x wps. Sorry about this inconvenience, but I tested 3 senab builds, 3 standard builds and 1 evilg123 build. Any build had a different problem, so my head was a bit confused.

But, I think will be good to fix the standard themes. They not have the background/fonts colours specified on cfg.

And now we have a database bug, maybe. The old ones are not recognized by the current build. I checked database x Database, but this not happens. I checked database directory, but both builds got the same. I don’t know what is going on. I had to rebuild all database to work on the new current build.

Thanks a lot, Jonathan Gordon.

ok, good this is fixed… investigate the databse thing more.. if it is indeed a bug then file a new report..


Available keyboard shortcuts


Task Details

Task Editing