Rockbox

  • Status Closed
  • Percent Complete
    0%
  • Task Type Bugs
  • Category Codecs
  • Assigned To No-one
  • Operating System Gigabeat F/X
  • Severity Low
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Paul Louden - 2007-02-10
Last edited by Thom Johansen - 2008-04-08

FS#6642 - Speex Noises

The speex codec occasionally interrupts my audio file with a sharp noise (like a high pitched burts of static). This happens at the same point in the file every time. For example, if it happens at 4:25, I can fast forward to just before this time and hear it again. The file plays fine on PC.

Closed by  Thom Johansen
2008-04-08 20:11
Reason for closing:  Fixed
Paul Louden commented on 2007-02-19 14:19

Confirmed, I can reproduce this in the simulator.

Paul Louden commented on 2007-03-08 05:27

Okay, this problem seems to be with Speex files encoded with an older encoder. I used 1.0.4 and the files had the pops, 1.1.12 encoded files are fine. But the 1.0.4 files play fine in Foobar2000, so to me at least suggests it’s still a decoder issue (just not quite as big of one. At least in one of the problem files, when re-created with the newer encoder, does not show the noises at the problems it did previously, and hasn’t yet.

Dan Everton commented on 2007-07-23 11:18

Any chance of a retest with the latest version in Rockbox? And if it still does it, can you attach a sample file?

Marc Guay commented on 2008-04-07 23:46

Has this been fixed or can it be considered out of date?

Thom Johansen commented on 2008-04-08 00:03

I’m pretty sure this has been fixed by now. I’ll close this if no new information is given in a week’s time.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing