Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Recording
  • Assigned To No-one
  • Operating System Iriver H300 series
  • Severity Low
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Mr_Rabid_Teddybear - 2007-02-23
Last edited by jdgordon - 2008-04-30

FS#6689 - Backlight on main unit stays on indefinitely when using "Clipping Light" > "Main and Remote Unit\

Actually, I got some different results on my H340 when testing while recording now. I can’t reproduce every time, but frequently, especially when choosing “Main and Remote Unit” as “Clipping Light” setting, the backlight, most notably on main unit, just don’t turn off again, sometimes not at all after pressing “record” button, sometimes after being turned on by first clipping. I would think this is not intended, as backlight staying on permanently will drain considerably on the battery. This was tested unplugged with “Backlight” setting set to 15 sec. Personally I would think that the durations set under “Display” settings for how long backlight should stay on should also be applied to the duration the clipping light stays on when activated. (Was tested with r12451)

Closed by  jdgordon
2008-04-30 14:38
Reason for closing:  Out of Date
Additional comments about closing:  

no response from OP… assume its fixed

Please check the “Clip hold time” setting. This is the time the backlight will stay on AFAIK, and IIRC the default value is quite high.

Default value are 60 sec it seems. I adjusted it to 20 secs. However, I was reporting due to backlight staying on for considerably longer than one minute. I’m more taking of testing up to 15-20 min before pressing stop. Especially easy to reproduce when “Main and Remote Unit” are set but remote are not plugged in. However, I can not get quite consistent results. This varies for every test I do here, but it is not consistent with neither “Display” backlight setting nor “Clip hold time” setting.

petur commented on 2007-02-24 21:54

Unable to reproduce on my H340. Tried many times in circumstances as above. Will review the code to verify.

petur commented on 2007-02-25 16:11

Does the clipping light option influence this (ie Main only ←→ Main and Remote)? Looking at the code it can’t, so I’m wondering if you specified it that it is a key factor in reproducing.

First of all, before testing further I’ve updated to r12480, cleared settings and set all backlight (main plugged and unplugged, remote plugged and unplugged) to 15 sec and also “Clip hold time” to the same.
Strange what you tell. Yes, I can no longer reproduce backlight staying on indefinitely, but it frequently stays on for 2-4 minutes when I have “Main and Remote Unit” set but remote not plugged in. With “Main unit only” it just stays on 15 secs.

petur commented on 2007-02-27 22:24

hmmmm… the only difference is that it would try to turn the remote backlight on. That is done by switching a pin on the controller (on GPIO 1), and that cannot take more time if no remote is present. Will search further…

Well, if noone else can reproduce, then it’s not much more to do about it….

petur commented on 2007-03-02 17:46

can you compile rockbox yourself? I could hand you a patch that doesn’t try to switch on remote backlight if no remote present.

I will have to set up a crosscompiler enviroment and read up on it (on wiki) first. But I guess I should manage that when I get the time. Unfortunately, it looks like it’s going to take atleast a week until I can find time for such. But you can post the patch here or I can PM you when I’m ready.

petur commented on 2007-05-01 22:40

is this still an issue?
If setting up a crosscompiler is too hard/timeconsuming, I guess I could give you a build.
Still, as far as I can see this shouldn’t be a problem…

Sorry for the delay. Haven’t looked at setting up crosscompiler yet. Guess I can manage, if I find the time. Probably not for a while still I’m afraid… Just tested again with todays build. Yes, backlight still stays on for strange and somewhat long durations after clipping if main & remote are set. With only main set it stays on for the 20 secs I currently have the clip hold time set for.

petur commented on 2007-08-10 22:59

Some bugfixing was done tonight in the backlight code, could you test this again with latest build? Thanks

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing