• Status Closed
  • Percent Complete
  • Task Type Bugs
  • Category User Interface
  • Assigned To No-one
  • Operating System iPod 5G
  • Severity Medium
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by ryran - 2007-03-05
Last edited by pondlife - 2007-06-15

FS#6735 - crazy unnecessary extra disk access on ipod video

Latest build (r12617) on both my 5.5g and 60gb 5g.
The disk spins up ALL THE TIME when browsing both the filetree (with dircache on and properly initialized) and the MENUS. Yes, I’m serious. Also worth noting is that quite often, pressing play to return to the wps from the filebrowser or menu results in the hard drive spinning up (not that it should make a difference, but this is using a wps with no graphics).

Turning off the show icons setting makes no difference–since the previous build I used was before JDG’s massive menu changes I initially thought the problem was related to reading the icons from the hard drive or something, but apparently not.

It really is insane. Most of the time, just pressing Menu from the wps results in a pause [before it displays] while the hd spins up. If you wait for the drive to spin down and start navigating through any of the menus, real quick you’ll hit another *pause* while the hd spins up. You can repeat the procedure.

I can’t understand how I could be the only one experiencing this, with two different ipods. In any case, if it’s necessary, I suppose I could go back through the archives and try to find out when it started. Oh, and I apologize if this is not the proper category–I gave it my best.

Closed by  pondlife
2007-06-15 06:45
Reason for closing:  Not a Bug
ryran commented on 2007-03-05 05:31

I had a minor breakthrough of sorts: I figured out that it depends on what font you use. For both of the 14pt fonts I’ve been using, it’s extremely apparent, but when switching to other fonts… sometimes it doesn’t happen at all. I’m just now testing, but with courB14, for example, the pause/spin-up doesn’t happen in the menus, but it does happen periodically in the filebrowser. It’s becoming clear that size has something to do with it. Using ter-u24b, I can get it to happen relatively easily in menus.

ryran commented on 2007-03-05 05:33

Note: the 14pt fonts I was talking about are home-converted vista fonts (Corbel bold & Calibri bold). Available upon personal request to help testing.

Can you reproduce it with any of the included fonts?

ryran commented on 2007-03-05 05:41

Yes sir. As I said, ter-u24 does it–just not nearly as well as my two favorites. I got tired of testing fonts so I stopped for the moment.

I was able to replicate your problem earlier, but since resetting my settings using Manage Settings –> Reset settings, I have not been able to replicate the problem. Could you try resetting your settings and see if that has any effect?

can you come onto IRC so you can share this font with us? (or email jdgordy at gmail)… Without much investigation it sounds like the font is too large for the font cache (how large is the /.rockbox/.glyphcache file?)

ryran commented on 2007-03-05 05:53

Random new tidbits.

I THINK it’s easier to reproduce if you’re playing music.
Limited testing of the following, but it appears to be 100% reproduceable (with the proper font–ter-u24b for example) in the filebrowser (with dircache enabled) when browsing into a directory that contains files or directories with accented/international characters WHICH HAVEN’T BEEN DISPLAYED YET. After letting the drive spin down, backing out, and then trying to come back into the directory, there’s no delay. This makes it pretty clear, at least in my head, as to what’s going on here.

ryran commented on 2007-03-05 05:54

In answer to Michael, yes it still happens after clearing my settings (or even clearing my whole .rockbox folder).

ryran commented on 2007-03-05 06:03

And of course I spoke too soon. Not 100% reproduceable now that I’ve rebooted. Hmmm. Anyway, I’ll stop posting blow-by-blow analyses now that I’m sure you all have enough to know where to look.

Project Manager

This is the font glyph cache in action. The font rendering code caches the glyphs that are displayed, but if the cache is full, it has to load the missing glyphs into the cache, causing a disk spinup. In your case, it looks like the glyph cache can’t hold all the glyphs that you are using, so it constantly flushes the cache and reloads.

The glyph cache is also stored on disk when you shut off, so it will be reloaded when you reboot the next time.

I have increased the glyph cache size in the SVN code, which should fix your problem. Please try the latest SVN build.

ryran commented on 2007-03-05 17:00

Only bumped up to 60k huh? I still think the answer is to make it user-configurable. Yes, most people will have no idea what it’s for, but that’s fine–then they’ll just ignore it.

Project Manager

Well, did it help or did it not?

ryran commented on 2007-03-06 20:47

Sorry Linus–I had already compiled my own build with the value bumped up to 250k.
Finally had some time today, so I tried out svn with your changes, but alas, 60k wasn’t enough for me–I still get pausing when browsing around, and it’s annoying (though obviously not as bad as before). So while I recommend we talk about how to make it user-configurable, I’ll be alright just editing it in my own builds.

Project Manager

OK, so with 250K it works fine?

ryran commented on 2007-03-07 04:12

Oh. Yes, totally.

petur commented on 2007-05-01 22:37

I assume this report can be closed?

ryran commented on 2007-06-15 04:58

I suppose it can. Personally, I wish the cache was bigger or user configurable, but I understand that’d be wasteful for most, considering I’m in the extreme minority.


Available keyboard shortcuts


Task Details

Task Editing