Rockbox

Tasklist

FS#6784 - Spurious button actions when using right button to select

Attached to Project: Rockbox
Opened by Adam Boot (rotator) - Saturday, 10 March 2007, 06:33 GMT
Last edited by Adam Boot (rotator) - Saturday, 10 March 2007, 06:34 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System Gigabeat F/X
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Step to reproduce on the Gigabeat:
1) Begin playing a track
2) Hold select to bring up the on play context menu
3) Select "Playlist"
4) Select "View Current Playlist" by tapping the right button

Result:
The BUTTON_RIGHT event selects "View Current Playlist" from the menu and the subsequent BUTTON_RIGHT|BUTTON_REL event selects the current track in the playlist viewer. The effect is that you can not view the current playlist without restarting playback of the currently playing track.

This bug manifests itself in the JPEG viewer when selecting "Quit" from the menu by pressing right and also in a couple other plugins.

It seems to me to be a bug in the Gigabeat keymappings when moving to the CONTEXT_TREE context from another context, but after a quick glance I don't see what's causing it.

This bug may also affect the iriver h1xx and h3xx keymappings since they are very similar.
This task depends upon

Closed by  Adam Boot (rotator)
Sunday, 11 March 2007, 03:15 GMT
Reason for closing:  Fixed
Comment by Jonathan Gordon (jdgordon) - Saturday, 10 March 2007, 13:20 GMT
If you can compile your own build... can you try adding action_signalscreenchange(); above the while(!exit) line in playlist_viewer.c (around line 631?)

I think that should fix it.. I tried without this on my h300 and didnt get the bug, so i cant test this out.
Comment by Adam Boot (rotator) - Saturday, 10 March 2007, 16:11 GMT
jdgordon, that seems to fix it. I'll try to hunt down all the other places it's happening too. The bug also appears in the sims, if you want to test that way.
Comment by Adam Boot (rotator) - Saturday, 10 March 2007, 16:13 GMT
Ah, I see you already fixed it for the plugins. The playlist viewer was the only other place I saw this bug.
Comment by Jonathan Gordon (jdgordon) - Saturday, 10 March 2007, 22:56 GMT
great, ill fix this a little later today

Loading...