FS#6801 - List scrolling much slower

Attached to Project: Rockbox
Opened by Steve Bavin (pondlife) - Monday, 12 March 2007, 08:46 GMT
Last edited by Steve Bavin (pondlife) - Monday, 12 March 2007, 08:46 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System Iriver H300 series
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


When browsing (or viewing any list), holding down the DOWN key used to scroll quickly. This no longer seems to happen, or the scroll rate is much reduced.

This problem was introduced sometime on the 11th March.
This task depends upon

Closed by  Steve Bavin (pondlife)
Monday, 12 March 2007, 19:29 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  My H340\'s UDA1380 died today, this was probably just it\'s death throes.
Comment by Linus Nielsen Feltzing (linusnielsen) - Monday, 12 March 2007, 08:54 GMT
Works just fine on my H300. I don't see much of a difference.
Comment by Paul Louden (darkkone) - Monday, 12 March 2007, 09:27 GMT
I don't see a difference on my Gigabeat or Nano. I know both aren't coldfire targets, but the code should've affected everything I believe.
Comment by Sacha (Angyman) - Monday, 12 March 2007, 10:28 GMT
With my iRiver H10 there seems also to be a loss in performance with the inclusion of kernel_on_cop
in SVN. Even if i dont use the equalizer theres no smooth scrolling possible from time to time.
Generally i was able to use three bands of the equalizer... now i can just use two bands. I noticed
that the main thread has two entries in the OS Stack each on one core running with
5% on the second and 45% on the first core. <- Is this how it should behave?