Rockbox

Tasklist

FS#6824 - Auto-skip directory doesn't work on iRiver H140

Attached to Project: Rockbox
Opened by Guy Davies (guyd) - Wednesday, 14 March 2007, 14:27 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi,

I've just loaded the r12757-070314 svn release on my iRiver H140 and tried to enable Auto-skip directory as described in the manual. Unfortunately, it doesn't behave as described. When it reaches the end of the list of songs in a single directory, it just stops and displays the list again with the first track highlighted. I've set Repeat to No, as instructed in the manual but that made no difference.

Guy

This task depends upon

Closed by  Steve Bavin (pondlife)
Wednesday, 14 March 2007, 16:13 GMT
Reason for closing:  Not a Bug
Comment by Nils Wallménius (nls) - Wednesday, 14 March 2007, 14:59 GMT
By Auto-skip directory do you mean Auto-change directory?
If so do you have this setting to on or random?
Did you start playing by selecting a music file in the browser or a playlist?

I could not reproduce this on my h320, it works as expected for me.
Comment by Guy Davies (guyd) - Wednesday, 14 March 2007, 15:11 GMT
Hi Nils,

I have it set to On.

I started by going to Database>Artist>Foo>Album Name>Track Name and clicking the select button (the big silver one on the front of the player).

I've got a folder structure of Artist Name>Album Name>File Name (usually based on the track name).

I have some 'Albums' with just a single file but the Artist has many Albums. So it's easy for me to test.

Rgds,

Guy
Comment by Nils Wallménius (nls) - Wednesday, 14 March 2007, 15:28 GMT
Ah ok. The Auto-change directory only works for actual directories and not for the Database.
If you would like this functionality in the database i think a feature request is in place
Comment by Guy Davies (guyd) - Wednesday, 14 March 2007, 15:30 GMT
Oh, and yes, I did mean Auto-change directory. I was getting mixed up with Anti-skip buffer in the same menu.

Rgds,

Guy
Comment by Guy Davies (guyd) - Wednesday, 14 March 2007, 15:35 GMT
Ah, OK. I'll go check the feature request database :)

Sorry for the noise.

Rgds,

Guy

Loading...