Rockbox

Tasklist

FS#6830 - Confirm dialogue "NEXT = yes" works as "NAVI = yes"

Attached to Project: Rockbox
Opened by Franz Rühmland (frause) - Wednesday, 14 March 2007, 19:04 GMT
Last edited by Nils Wallménius (nls) - Wednesday, 14 March 2007, 22:50 GMT
Task Type Bugs
Category Language
Status Closed
Assigned To No-one
Operating System Iriver H100 series
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Either the text or the button mapping is wrong in the confirm dialogue. NAVI confirms when the text says "NEXT = Yes". Personally I would prefer RIGHT/NEXT.

A search for "confirm" in the manual results in one place where it says RIGHT and one where it's RIGHT or NAVI.
This task depends upon

Closed by  Nils Wallménius (nls)
Wednesday, 14 March 2007, 23:32 GMT
Reason for closing:  Fixed
Additional comments about closing:  Bagder fixed this in a recent commit
Comment by Nils Wallménius (nls) - Wednesday, 14 March 2007, 22:17 GMT
Other's have reported the string to read the intended NAVI = Yes so if you really have NEXT = Yes on an iriver h100 (not h10) you must somehow have installed a h10 .lng file, try to reinstall rockbox, unzip the complete zip file, not just the rockbox.iriver file and see if the problem is still there.
Comment by Franz Rühmland (frause) - Wednesday, 14 March 2007, 22:35 GMT
What am I doing wrong? "NEXT" is in the english.lng in my downloaded zip. NAVI is not.

$ rm -rf .rockbox rockbox.iriver && wget -q http://build.rockbox.org/dist/build-h100/rockbox.zip && unzip -q rockbox.zip && strings .rockbox/langs/english.lng |grep Yes
;NEXT = Yes
Yes - Recent only
$
Comment by Nils Wallménius (nls) - Wednesday, 14 March 2007, 22:49 GMT
I'm sorry my sim was for the iriver h120, most people refer to h100/h110/h120/h140 simply as h100 but as you know they are in fact different builds, I now built another sim and could reproduce the problem, it seems like the lang build system matches the h100 to h10 target specific strings _when_ the h10 string comes after the h100 one. Reordering the stings in the lang file could work as a workaround but it's not the Right Way (tm) to do it :-) be patient it will hopefully be fixed soon.
Comment by Franz Rühmland (frause) - Wednesday, 14 March 2007, 23:09 GMT
It works now. Thanks!

Loading...