FS#6842 - Viewers are not visible in "open with..."

Attached to Project: Rockbox
Opened by Simon Menzel (Rincewind) - Saturday, 17 March 2007, 17:20 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System Iriver H100 series
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


With the current svn build (rev. 12823), the list that shows the viewers when you enter "open with..." in the context menu on a file is empty.
I and serveral other people in IRC confirmed this for the H1xx series, bluebrother's iPod doesn't get the bug.
It seems that the list is only empty visually, if one of the empty lines is selected, then the viewer starts.
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Sunday, 18 March 2007, 06:31 GMT
Reason for closing:  Fixed
Comment by Dominik Riebeling (bluebrother) - Saturday, 17 March 2007, 17:31 GMT
That bug got definitely introduced with r12821 -- Unify the way functions are called from menus. It's easily to reproduce using the h120 sim. I can select an entry of the invisible list, but it seems to be always chip8 (which is the first entry in the list).
The problem does not occur on ipod mini sim & target.