Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Operating System/Drivers
  • Assigned To No-one
  • Operating System All players
  • Severity High
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by bluebrother - 2007-03-20
Last edited by bluebrother - 2007-03-21

FS#6863 - hard hang on "nothing to resume" splash

Sometimes Rockbox hangs on the “nothing to resume” splash after finishing a playlist. I found this to be pretty easy reproducable in conjuntion with the new main menu:

- play something
- go to the main menu
- go back to the wps
- wait for the playlist to finish (and make sure the screen you entered last before going back to the wps is the main menu, otherwise the bug will not occur)
- when the playlist finished, the splash “nothing to resume” comes up and the player hangs hard. It doesn’t crash as touching the clickwheel turns on the backlight but there is no other way to exit that splash than resetting the player. I assume the splash gets called in an endless loop.

There is an additional issue which I heavily assume to be related:
- play something
- go to the main menu
- go back to the wps
- hold play/pause to stop playback (on ipod)
Playback will fade out and right after that the splash “loading” appears and playback starts again. To stop playback you need to go to some other screen. If the last screen was something different than the main menu this doesn’t occur. The problem also exists on devices with a dedicated stop button (like h100)

I have observed and confirmed the described behaviour with both ipod mini and h120 with current builds. The problem exists at least since a couple of days but as I usually use the file browser I might have missed it for quite a while. I highly assume this to be caused by the “go back to the last selected screen” logic of the new main menu.

Closed by  jdgordon
2007-03-29 14:20
Reason for closing:  Fixed
Additional comments about closing:  

hopefully… reopen if svn is still no good

fml2 commented on 2007-03-20 13:28

I've also observed the behaviour of the "additional issue" (but not the "main issue") with one of the recent builds (don't know the exact number). And was very confused. I had to go to FM radio to stop playback.

Sorry, but this issue isn't fixed completely. I still can reproduce both mentioned issues reliably on my h120. On the mini I had both issues reappearing, but it looks like they don't occur that reproducable as before.

I tried r12879 and even replaced the complete .rockbox folder on the h120 to make sure I have no traces left.

fml2 commented on 2007-03-21 20:22

Here is a real patch. Please commit it asap since the bug is very serious. Menu code needs rework IMHO. It should be better structured.

fml2 commented on 2007-03-21 20:29

This still needs a better fix since there should be no "Nothing to resume" splash if the playlist naturally comes to the end. (Now the splash is shown as if the user had requested to resume playback.)

Ok, I found another thing: the playback-not-stopping bug seems to occur only if you go to the wps using the play key from the menu. If you use the "Now playing" entry a press of "stop" works as expected. From my test in the sim this seems to apply also to the "nothing to resume" splash bug.

test me!

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing