Rockbox

Tasklist

FS#6895 - Sansapatcher 0.2 Bootloader not finding rockbox.e200 in /.rockbox/ reliably

Attached to Project: Rockbox
Opened by powers (kpowers11) - Saturday, 24 March 2007, 03:34 GMT
Last edited by Paul Louden (Llorean) - Saturday, 24 March 2007, 05:42 GMT
Task Type Bugs
Category Bootloader
Status Closed
Assigned To No-one
Operating System Sansa e200
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The new Sansapatcher 0.2 bootloader doesn't find rockbox.e200 in my /.rockbox/ folder.
This task depends upon

Closed by  Barry Wardell (barrywardell)
Saturday, 24 March 2007, 20:59 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  Looks like this was not a problem with the Rockbox bootloader.
Comment by Paul Louden (Llorean) - Saturday, 24 March 2007, 03:45 GMT
Are you saying that if you just put it in the /.rockbox/ folder, without a second copy anywhere else, Rockbox will not boot?
Comment by powers (kpowers11) - Saturday, 24 March 2007, 05:05 GMT
I am saying that I needed to move rockbox.e200 out of the .rockbox directory and into the main directory in order for it to be found by the bootloader. In the previous Sansapatcher version, I was able to keep rockbox.e200 in the .rockbox directory and the bootloader would find it.
Comment by Paul Louden (Llorean) - Saturday, 24 March 2007, 05:13 GMT
I asked a yes/no question, and you answered it with more vagueness. What do you mean by "will not find it" if you don't mean "Rockbox doesn't boot."
Comment by powers (kpowers11) - Saturday, 24 March 2007, 05:15 GMT
I get a message saying the bootloader can't find rockbox.e200 or rockbox.mi4 when rockbox.e200 is in the .rockbox directory. If I move the file to the main sansa directory, rockbox boots just fine.
Comment by Paul Louden (Llorean) - Saturday, 24 March 2007, 05:19 GMT
Do you get the message, and then Rockbox still boots, or do you get the message, and then it doesn't boot? I keep asking whether Rockbox actually boots, and you seem to keep avoiding that simple question. I'm not asking about ANYTHING but whether Rockbox still starts or not.
Comment by powers (kpowers11) - Saturday, 24 March 2007, 05:20 GMT
I get the message and rockbox does not boot.
Comment by Paul Louden (Llorean) - Saturday, 24 March 2007, 05:24 GMT
Alright, at the top of the screen, what number does it say your bootloader is? (The numbers after the letter 'r').
Comment by powers (kpowers11) - Saturday, 24 March 2007, 05:28 GMT
12896-070323
Comment by Paul Louden (Llorean) - Saturday, 24 March 2007, 05:35 GMT
Strange, I have the exact same bootloader, and have no problems.

Just to verify, before the move, the file is G:\\.rockbox\\rockbox.e200, right? (Maybe with a different letter, but that EXACT folder structure and name)
Comment by powers (kpowers11) - Saturday, 24 March 2007, 05:40 GMT
Yes, that EXACT same folder structure. In fact I have moved the rockbox.e200 file back and forth several times to verify the problem. I am not upset, I can still get the program to work. I just thought you might be interested in this observation.
Comment by Paul Louden (Llorean) - Saturday, 24 March 2007, 05:41 GMT
Well, the odd thing is, the exact same bootloader works fine for me, with rockbox.e200 in the /.rockbox/ folder. Which means it IS still looking there, it's just not finding it on your player for some reason.
Comment by powers (kpowers11) - Saturday, 24 March 2007, 05:45 GMT
I do find that odd. I can get it to work when I move rockbox.e200 (not copy it) to the main directory. When I move it back to the .rockbox directory the bootloader doesn't find it. Oddly, in the previous Sansapatcher version, I had no problem with this and could keep the rockbox.e200 file in the .rockbox directory.
Comment by Jonathan Gordon (jdgordon) - Saturday, 24 March 2007, 12:53 GMT
im betting a typo in /.rockbox or case problem... the sansa bootloader has NEVER not checked .rockbox before /..

delet your current .rockbox folder and rockbox.e200 and extract the rockbox.zip from the recent builds page...
Comment by powers (kpowers11) - Saturday, 24 March 2007, 15:28 GMT
Let me preface this by saying thank you for your patience. I applaud your efforts. I tried several things including installing a previous version of the bootloader I had archived and which I knew worked. It resulted in the same condition (to my surprise). I tried simply extracting the current rockbox build over my previous installation (my current update procedure) which resulted in the same problem. However, following your final suggestion, I completely deleted my rockbox build and re-extracted the current build to my device. I don't know why it worked since the .rockbox directory had never been changed during my updates... but it did. I apologize for not trying this simple fix in the first place and your bootloader and sansapatcher appear to be solidly constructed works of coding genius. Continue your efforts and know that you are doing a great job.

Loading...