Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category User Interface
  • Assigned To No-one
  • Operating System Sansa e200
  • Severity Low
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Matthias Wientapper - 2007-03-24
Last edited by Michael Sevakis - 2007-08-03

FS#6900 - LCD goes white while playing music

<pre>

  1. Running Revision: 12900
  2. Bootloader installed by sansapatcher 0.2 (12896)
  3. WPS: icatcher
  4. battery_bench running in the background

</pre>

After several hours of playing music the screen turned white. After normal power down everything is back to normal. Unfortunately I cannot say when exactly it happens because its nearly impossible to tell because the backlight is off.

Music playback continues normal, backlight thread operates normal, keypad is still responding, I can toggle between menu and WPS - but screen remains white.

Closed by  Michael Sevakis
2007-08-03 14:50
Reason for closing:  Fixed
Additional comments about closing:  

Caused by messing with DMA during updates. That isn't done now and a melt has never happened since.

Matthias Wientapper commented on 2007-03-24 21:10

Also happening with rockbox_default.wps

Matthias Wientapper commented on 2007-03-25 16:15

Wrap up of some additional information, gathered in IRC, 2007-03-25, 17:33

User foolsh observed the same "whitescreen of death" on his sansa with most recent SVN builds.
It seems like this behaviour was introduced a few days ago in SVN.
Since then there have been modifications in in kernel.c and lcd-e200.c

Matthias Wientapper commented on 2007-03-25 16:57

I observed another wsod while the device was playing and the background light was off. As the peak meter was not showing any activity I touched the wheel to switch on the backlight and I observed how the frozen screen faded slowly to white.

(Played music, switched tracks forward/backward, toggled menu/playback)

Matthias Wientapper commented on 2007-03-25 18:08

applied http://www.rockbox.org/tracker/task/6908 - no hang up yet

Michael Sevakis commented on 2007-05-31 21:10

Somwhat preliminary but setting register 0x6000a000 to 0x80000000 instead of 0 seems to completely kill this (done in ata-e200.c). I ran graphically intensive plugins for about an hour with not a single meltdown. Switching the register back to 0 resulted in a screen melt in about a minute or two. The screen smoothness is much greater as well. What also needs to be part of the fix is using the clocking already set up by the Sansa preloader and not using the setup for iPods - just for speed reasons it seems.

bodymind commented on 2007-06-08 11:45

happened to me on the original firmware… when the database was updating… so it isn't an rockbox-only bug…

Michael Sevakis commented on 2007-06-09 02:26

I'd suggest now updating since I changed it to not do anything to stop/start the LCD controller during updates. I've been running it with heavy updating plugins for hours now without any melting. The other fix only made it more rare. You might see a tiny amount of additional artifacts now but I'd rather have the screen keep running for now and figure out synced updating later. Besides, those waits in there slowed the whole system a lot.

Barry Wardell commented on 2007-08-01 13:55

Is anybody still experiencing this? It seems like it might not be a problem any more?

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing