Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System SW-codec
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 1
  • Private
Attached to Project: Rockbox
Opened by Todd Uzzell - 2007-03-25
Last edited by Steve Bavin - 2008-02-09

FS#6904 - Directory Skip (Right or Left, short + long) causes freeze

When using the directory skip feature during music playback (press joystick right or left, short + long) the player freezes up 50% of the time. I am using the latest build as of 3-24-07 (r12903-070324 , but this bug has occurred for all the versions tried over the last few months. When the iAudio X5 is frozen, the player can be turned off after holding the off slider for about 10 seconds.

Closed by  Steve Bavin
2008-02-09 14:57
Reason for closing:  Fixed
Additional comments about closing:  

Seems to have been fixed (by MoB, probably).

2008-06-25 : A request to re-open the task has been made. Reason for request: New builds hang the e200 and x5. (these are the only ones I have to test with)
Michael Sevakis commented on 2007-03-25 20:33

Hmmm…a big scheduler hole I’m about to plug up _may_ have something to do with this. It has caused locks during backlight fading on H120 and is probably the reason for a blocking violation someone got when plugging USB on an H140. 50% of the time seems too often to have it be the cause but after you see the commit, test again.

Michael Sevakis commented on 2007-03-25 20:53

Never mind. I got to checking it and it doesn’t appear to be playback lock or anything but something UI related. It locked but the music kept playing anyway…which is the first time I’ve ever seen anything like that. Yet another oddness thing to look into. :P

philip kao commented on 2007-04-29 08:07

I just tried it using the build from 4/27, and the first time I did it, it locked up. Strangely, when I restarted the player, it was in the next directory! Then I tried to get it to lock again, but it wouldn’t lock up any more. Strange…

Steve Bavin commented on 2007-07-08 12:44

Hi Todd (and Phil),

Is this still a problem with a current build?

Robert Keevil commented on 2007-07-08 13:26

This is reproducible for me on current SVN using an ipod.

Steve Bavin commented on 2007-07-31 10:46

I can’t get this to lock up at all (on H300), maybe someone who has a reproducible recipe could post it along with their .cfg?

Steve Bavin commented on 2007-08-16 10:17

Again - please can someone who can repro this on the current SVN post their config.cfg file?

philip kao commented on 2007-08-16 19:48

I haven’t had my player for the past month or so, but I just got it back. I don’t think I can reproduce this error any more, but I’ve only tried it once. I’ll go exploring later tonight.

philip kao commented on 2007-08-17 21:15

Still happens. It worked the first few times I did it, but then it froze about half of the time.

Steve Bavin commented on 2007-08-18 11:27

Hi Philip, could you attach your config.cfg please.

philippe Miossec commented on 2007-08-20 21:12

As I describe here : http://forums.rockbox.org/index.php?topic=12119.msg92646#msg92646 it seems that I have the same problem on iriver h140 with the last build (and that for months ago).

I could reproduce the bug with the default settings…

Tim Pickersgill commented on 2007-09-20 17:45

Can someone change the title/summary line please?? Looks like this has been reproduced on iaudio X5, ipod and iriver h140.

I’ve been seeing this on my H140 for a many months also. resetting the iriver whilst driving is quite difficult/annoying ;-) Reproduced again today with a clean (created a new .rockbox directory, didn’t change any settings) r14783-070920 build.

I can confirm that this occurs with folders of .mp3, .ogg and .wma files, i.e. doesn’t appear to be codec specific.

When the iriver freezes, the display flickers between two different screens and keys appear to repeat indefinitely. Pressing stop, for example, may result in flickering between the WPS and file browser. Two display threads running??

I should be able to test this on an H340 in a couple of days, if that helps??

Davy Kager commented on 2007-11-03 16:23

I’ve been trying to crash Rockbox for half an hour or so, and it didn’t freeze just a single time (on an iAudio X5, latest SVN). I suppose it must be config-dependent.

Nils Wallménius commented on 2007-11-05 16:38

Could any of you who have been able to reproduce this try with a current build. The recently committed buffering changes are likely to have affected this.

Tim Pickersgill commented on 2007-11-06 21:32

Tried with build r15497-071106 on h140, directory skip still hangs the player oocasionally, but seems to be less often. Also, I have often been able to shut down by holding Stop once the player has hung, which wasn’t working with older builds (e.g. r15250).

Hangs now lock up the display completely, although playback will often, but not always, continue. I haven’t seen any flickering issues like before.

I’ll keep investigating, to see if I can spot any patterns to when this is still hanging…

Tim Pickersgill commented on 2007-11-06 22:36

Firstly, forgot to mention in my previous comment that this is with a clean .rockbox folder. (moved my regular .rockbox folder out of the way first)

Tested again using play+right to skip to next album to see if this made any difference.

Skipping through the folders I use for codec performance testing, moving from a flac folder to lame folder was okay, but then from lame to mpc left the player constantly skipping to the next track (as if the right button press was repeating even after I had actually released it) although the player continued to respond to button presses and I could stop playback and restart.

Skipping to nero, then vorbis, then wma was okay, and skipping to wv then hung the player, requiring a hard reset.

This happens consistently when I repeat the test.

Tim Pickersgill commented on 2007-11-12 21:00

Firstly, forgot to mention in my previous comment that this is with a clean .rockbox folder. (moved my regular .rockbox folder out of the way first)

Tested again using play+right to skip to next album to see if this made any difference.

Skipping through the folders I use for codec performance testing, moving from a flac folder to lame folder was okay, but then from lame to mpc left the player constantly skipping to the next track (as if the right button press was repeating even after I had actually released it) although the player continued to respond to button presses and I could stop playback and restart.

Skipping to nero, then vorbis, then wma was okay, and skipping to wv then hung the player, requiring a hard reset.

This happens consistently when I repeat the test.

philippe Miossec commented on 2007-11-29 12:01

I still have the problem with the build r15791-071124 with my H140.
And I must add that, contrary to some previous message from other persons, when rockbox hang, NOTHING is working (nor the screen is changing, nor some buttons responding).
The only thing that work is the hard reset :)

I don’t know if it could help but it seems to happen perhaps more often when I failed to skip the directory (short + long button press) and instead I change 2 times of songs ( short + short button press) and immediately after that, I retry to skip the current directory. I imagine that the problem happen when rockbox is loading a song and when ask it to skip the directory.

Nicolas Pennequin commented on 2008-01-08 22:28

Is someone still experiencing this issue? I just made some tests and everything worked fine.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing