FS#7007 - Space padding of %ce tag

Attached to Project: Rockbox
Opened by Jiri Techet (teeky) - Tuesday, 10 April 2007, 19:25 GMT
Task Type Bugs
Category Themes
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


The tag %ce is space padded now which didn't use to be. This padding does not make much sense as for example

%cb %ce

may cause double space, e.g.

Apr 9

The example in the wiki documentation is also incorrect, the given code produces

Sun, Jan 01, 04:10:42
This task depends upon

Closed by  Peter D'Hoye (petur)
Wednesday, 11 April 2007, 21:36 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  by design
Comment by Jiri Techet (teeky) - Tuesday, 10 April 2007, 19:30 GMT
OK, seems the two spaces in the example were removed after adding the bug report. Suppose that period (.) is the space. Then the displayed date is

Comment by Nicolas Pennequin (nicolas_p) - Wednesday, 11 April 2007, 17:14 GMT
I corrected the wiki, but what's the problem with the space padding ? It used to be before so what you say isn't correct.
You say it could cause double space, but that's precisely the point of blank padding, so I don't see where there's a bug.
Comment by Jiri Techet (teeky) - Wednesday, 11 April 2007, 21:21 GMT
Ah, you are right, I hadn't noticed this behaviour before.

Anyway, I don't understand the purpose of the padding. Tags like %cl and %ck don't have this padding, why %ce has? How can I get

month space day-of-month-without-leading-zero

which always contains only one space? As I said, it is not possible with %cb %ce.
Comment by Peter D'Hoye (petur) - Wednesday, 11 April 2007, 21:35 GMT
the code of the parser has the following:


so it seems to me %ce = %cd + padding

I'll close this report, feel free to request it re-opened if you feel my understanding isn't correct