Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Operating System/Drivers
  • Assigned To No-one
  • Operating System Iriver H100 series
  • Severity Low
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by pabouk - 2007-04-13
Last edited by MikeS - 2008-02-20

FS#7025 - PANIC after unplugging USB

I booted iriver H120 into the bootloader USB mode, upgraded the firmware to r13142-070413. Then I unplugged USB and let the new firmware boot. After one minute I plugged the USB again (Rockbox was running), copied several files and unplugged. Rockbox ended in panic state:
*PANIC*
Blocking violation
B→*T

I could not reproduce the bug later.

Closed by  MikeS
2008-02-20 12:36
Reason for closing:  Fixed
Additional comments about closing:  

Mixed blocking types supported.

MikeS commented on 2007-04-14 03:38

This is the second report of this and frankly now I’m not sure why it should still occur. It happened on an H140 btw.

is this still an issue?

MikeS commented on 2007-09-29 08:05

I think it still can be, yes. It is not currently safe to mix blocking types in a single queue so as long as that isn’t the issue potentially exists.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing