• Status Closed
  • Percent Complete
  • Task Type Bugs
  • Category User Interface
  • Assigned To No-one
  • Operating System Sansa e200
  • Severity Low
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by gregpend - 2007-04-15
Last edited by Marc_Guay - 2008-03-31

FS#7032 - Database initialization hangs

Database initialization is hanging on my sansa. I recently copied all my tracks off, converted them to AAC using winamp, then copied the aac tracks back on. Now when I try to re-initialize the database it hangs completely on 3107, every time. It’s completely consistent. The only way to get out of it is to hold off for 15 seconds or so.

I’ve had bad luck with AAC files so far. I tried experimenting with just a few tracks with varying success. Very often the AAC tracks wouldn’t get into the database after an update where the old mp3 versions were just fine. I’m on the April 13th distribution.


Closed by  Marc_Guay
2008-03-31 23:02
Reason for closing:  Fixed
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407

Database initialized error-free with the file from  FS#8500  (which has a gigantic comment tag).

If you can identify which file it’s hanging on, it would be helpful for us.

As well, you are aware that converting from MP3→AAC is a significant quality loss.

I know it’s a loss, but it means I can fit twice as many songs in the player. Any ideas of how I can figure out which song it’s hanging on? I have over 1700 tracks….

successively (re)move tracks to the player and check if it still hangs – I don’t think there is any other option than just iterating to the hanging file …

Some strange behavior:

As suggested I tried to find out which file was causing the problem by deleting half the tracks from my player and it hung on 1702 tracks. It didn’t seem to matter how many tracks I have, it always froze. I tried taking all but 1 directory with 1 song in it off the player and it hung and the screen degraded as soon as I try and initialize the database.

Next I tried deleting ALL music tracks off the sansa and it STILL hung! It says Building Database… 387. With no music files what can it be crashing on? Could it be something else that has been corrupted? I have reloaded .rockbox and loaded today’s build and it still hangs.

In the end I installed my old mp3s back on and it all works just fine.

I made the aac files using the winamp llc-aac converter. Here’s a sample track, it’s the one I used for the single track.

any ideas….

Do you have any non-music files on your player, other than the .rockbox folder?

Besides some playlists there’s the default .bmps and a couple of .movs that come with the sansa, as well as the sansa system files. Nothing else.

I re-converted my mp3 using he-aac and all my tracks get detected now, however playback pauses every 3-5 seconds. It plays for 3-5, then stops for 1-2 seconds, then plays another 3-5 seconds. What can I provide that would be useful in solving this issue? I’ll post one of the tracks if you like.

This is a CPU issue, AAC uses more CPU than MP3. Make sure you’re not using EQ, crossfeed or any peak meters. Or maybe try a lower bitrate. Support issues should be on the forum and IRC, not Flyspray…

Were the original problematic files normal AAC, or HE-AAC? As you mentioned HE-AAC, I’d like to mention that it’s not supported.

Hello -

I have a Ipod 60gb Video and I’ve just installed Rockbox for the first time. While initializing the database for the first time, it hangs and indicates:

Data abort

Any ideas?

I have a pretty full Ipod with other (non-music) files too.

Thanks for the help!


I have the same problem over here. I own a Sansa e280 and the database gets stuck at #1027. I can’t remember putting any new audio files on so I guess it’s a problem with the data. Most of my audio files are vorbis. Besides the fact that the update process hangs audio starts to stutter after some time and the the keys don’t respond after some time, but music keeps on playing.

Besides finding the obstructing file wouldn’t it be a great idea to showing the file names while the update process is proceeding?

I found at least one bug: when updating the database, it would crash after some time. After finding the files causing the problem, I noticed they had a very long entry in the “comments” section of the ID3 tag. I deleted the whole comments, tried again, and updated without problems.

I found that on my sansa there was actually a file that was non accessible. As I couldn’t remove it I had to format the whole disk. Now it works again. Anyway it’d be nice if one could access an error log or see at least the current file which is updated.

Remove the comments from your files (mp3tag does the job fine), try updating the database again, reboot unit.

I had this problem, and i’ve tracked it down to a single file with some very borked id3 tags (attached). Either that or the Stone Roses’ second album sucked so badly it crashed my player. Anyway, it’d be good if rockbox could handle even this being thrown at it.

hm, seems my file is too large for this. email me to get a copy of the broken file.

petur commented on 2008-01-25 21:23

Can you test again with the latest build? A bug in the tag length check was fixed that might have caused an issue like this one


Available keyboard shortcuts


Task Details

Task Editing