Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category LCD
  • Assigned To No-one
  • Operating System Gigabeat F/X
  • Severity Medium
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Henry Lawson - 2007-04-16
Last edited by Steve Bavin - 2007-04-16

FS#7037 - Gigabeat X series - Backlight does not function

The backlight on my Toshiba Gigabeat X series player remains switched off while the player is on. This bug is evident in all rockbox builds since r13102-070411.

In communication with people on IRC it appears this bug is only evident in X series players as all F series players have full functionality. Furthermore it was suspected the issue may be traced to a commit made by Karl Kurbjun. See below:

12 Apr 07:21 Karl Kurbjun

firmware/target/arm/gigabeat/meg-fx/ata-meg-fx.c
[diff]

Fix the backlight and led bugs from my last commit

Then again I’m not a developer so i really have no idea.

Closed by  Barry Wardell
2007-04-22 23:32
Reason for closing:  Fixed
Henry Lawson commented on 2007-04-16 21:07

It should be noted that without a functioning backlight the player cannot be used. Making all of the latest builds for rockbox useless.

fubz commented on 2007-04-16 22:46

The backlight SOMETIMES turn off on the F series too. Its not all the time, and I can’t seem to reproduce it. It just happens at random and it can be turned back on by getting to the LCD Brightness settings. Sometimes it will also randomly turn back on at button press. But usually I have to turn the unit off then back on.

Its been happening since one of the april builds - i’m sorry I don’t know which one. my rockbox.gigabeat file modified time is April 11th

Henry Lawson commented on 2007-04-16 23:24

For the X series, rebooting the player does noting, as does resetting the settings on startup, the backlight remains switched off either way. Tonight i will atempt to turn the brightness up by going into settings but it will probably be very difficult.

fubz commented on 2007-04-17 00:04

It helps if you are in a dark room with only a very little light to see the screen with the backlight off

Henry Lawson commented on 2007-04-17 06:51

Update:

I loaded the latest current build and managed to find my way to the back light settings section by writing down the number of button pushes and by vaguely following the line selector line across the screen and it seemed that no matter how much i changed them the back light remained off. Which i guess shows that their is 0 backlight functionality in Gigabeat X series players.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing