FS#7139 - Unidentified instructoin in vorbis codec

Attached to Project: Rockbox
Opened by Danny Attar (dannya) - Wednesday, 09 May 2007, 19:53 GMT
Task Type Bugs
Category Codecs
Status Closed
Assigned To No-one
Operating System iriver H10
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


I have compiled and installed the latest SVN on my iriver H10 5GB, and it can no longer play vorbis files. Rockbox hangs with the message "Unidentified instruction at 00069054". MP3s still play OK.
Here is my rockbox-info file:
Target: h10_5gb
Target id: 24
Target define: -DIRIVER_H10_5GB
Memory: 32
CPU: arm
Manufacturer: iriver
Version: r13366M-070509
Binary: rockbox.mi4
Binary size: 449536
Actual size: 448656
gcc: arm-elf-gcc (GCC) 4.0.3
ld: GNU ld version 2.16.1
Host gcc: gcc (GCC) 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)
Host system: Linux
This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Thursday, 10 May 2007, 19:11 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  seems this was a problem with the posters build which is cleaned out according to him.
Comment by Dominik Riebeling (bluebrother) - Wednesday, 09 May 2007, 22:46 GMT
Do you have any patches applied to your build? The version string shows that there have been modifications somewhere in your svn tree. Have you tried with an official build?
Comment by Danny Attar (dannya) - Wednesday, 09 May 2007, 23:24 GMT
No patches that I am aware of. I obtained the source with "svn co svn:// rockbox". Do you think I should do a clean reinstall?
Comment by Danny Attar (dannya) - Thursday, 10 May 2007, 18:24 GMT
I downloaded the source again and rebuilt the binaries and now Rockbox works fine. I think there must have been some corruption in my original copy of the source tree.
I am happy for this bug to be closed.