Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category User Interface → Themes
  • Assigned To No-one
  • Operating System iPod 4G Grayscale
  • Severity Low
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by gree665 - 2007-05-12
Last edited by nicolas_p - 2007-05-21

FS#7155 - Wrong day of the week displayed in WPS (%ca)

I am running firmware from May 10th on my Ipod 4g Grayscale. My WPS displays the wrong day of the week (although the date and time are correct). I am using %ca to display the day of the week. When I go to the settings to the menu that changes the date and time, the correct day of the week is displayed there.

Closed by  nicolas_p
2007-05-21 12:03
Reason for closing:  Works For Me
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407

Issue has disappeared for the reporter and can't be reproduced. Please request reopening if the problem reappears.

works here…

Have you checked the new RTC tags format ?

Warning: Undefined array key "useheading" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 1099 Warning: Undefined array key "target" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 Warning: Trying to access array offset on value of type null in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557

I am using the tags from the wiki page. The line from the WPS is

%al%ca, %cb %cd %ar%cl:%cM%cp

Which shows the day of the week as Sun (today is Tuesday). I replied to someone else's post about this in the forums:

http://forums.rockbox.org/index.php?topic=9182.0

Update: Today is Thursday, my RB WPS says its Tuesday. Since the Day of the week is always 2 days behind, I thought I would set the year to 2008, making the day of the week Saturday, then if the WPS is 2 days behind, it would display Thursday, and the weekday and day of the month would both be correct.

When I made the change though, the WPS said Saturday. I then changed it back to 2007, and the WPS now says the correct day! I don't know why, but it seems to be fixed.

So this was a bug with the RTC and not the WPS code… Maybe I could close this task ?

Well originally the date was correct when I viewed it from the 'set time/date' screen, only wrong on the WPS screen. So I don't know where the bug is. Maybe you should close it, and we'll see it if ever comes up again.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing