Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by PaulJam - 2007-05-13
Last edited by bluebrother - 2008-04-05

FS#7162 - Playback menu in plugins

1. When pressing the stop button (not the menuentry) in the Audioplayback menu of a plugin (e.g. solitaire) in the uisimulator, it crashes with the following error message:
[code]pause
We open the real file ‘archos/.rockbox/nvram.bin’ Fatal signal: Segmentation Fault (SDL Parachute Deployed)
* glibc detected * corrupted double-linked list: 0xb7ed9358 ***
Aborted[/code]

2. When selecting the “Pause / Play” entry in the playbackmenu while playback is stopped, then the statusbar indicates playback but nothing is playing. The WPS then shows “No file!”. (I was only able to reproduce this in the uisimulator but according to JdGordon this happens on his target (e200) too)

The uisimulator (H300) was built from source revision 13377

Closed by  bluebrother
2008-04-05 18:33
Reason for closing:  Fixed
Additional comments about closing:  

seems to be fixed, closure requested by poster.

The first issue doesn’t happen anymore with revision 14120.

I just tried to recreate the 2nd scenario but quickly realized I couldn’t find the “playbackmenu” or a “Pause/Play” entry anywhere… Is this out of date?

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing