Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category User Interface
  • Assigned To No-one
  • Operating System Gigabeat F/X
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by giraffe - 2007-05-22
Last edited by midgey34 - 2007-07-30

FS#7202 - Power and A button functionality switched between each other

I have a Gigabeat F40 and just be sure just today I upgraded to Today’s (May 22nd 07) build (this issue was still happening before the upgrade) and the latest boot loader. It seems that the functionality of the Power button and the A button is switched between the two buttons. In the manual for this Firmware it states that pressing Power while having music playing and while in WPS will stop playback and display the file list and that pressing the A button will keep the music playing and display the file list. In reality the Power button does not stop the playback and the A button does. Same behavior occurs when using Virtual Keyboard: according to the manual pressing Power exits the virtual keyboard without saving any changes and pressing the A button; what happens is reversed: pressing Power saves the change and pressing A cancels the change. Either the manual or the key mappings have to be changed.

Also want to thank everyone involved in this project, I absolutely love it :)

Closed by  midgey34
2007-07-30 20:26
Reason for closing:  Not a Bug
Additional comments about closing:  

The functionality of A and Power were switched and the manual was updated accordingly.

nls commented on 2007-05-22 19:30

Are you absolutely sure that you installed the update correctly and safley removed (unmounted) your player from your computer?
The behaviour of the power and A buttons were switched on Apr 13 in the code and later in the manual, so what you read in the
manual is correct and the behaviour that you describe is not.
Please try to reinstall a new build, and test again.

I will try and install tomorrow’s build and yes I did do the Safely Remove USB device procedure.

I will try and install tomorrow’s build and yes I did do the Safely Remove USB device procedure.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing